Question

Issues with song info in car, android phone bluetooth connected

  • 8 August 2019
  • 0 replies
  • 26 views

For the last 5 years I've had a Motorola Droid Turbo, running Android 6. I kept it for so long because the hardware was great (still is, but battery issues). For the last 7 or 8 months I've been listening to SoundCloud in my car, connected via Bluetooth (Lexus RC 350 if it matters). The app had minor issues that I've seen other support topics talk about, but nothing that wasn't easily resolved as I started the car. A few days ago I got a new phone, Motorola z4, running latest Android version. Now I have an issue that is actually frustrating enough to notify you about it.

When I start the app, the song info is delayed by a few seconds but playback time counting up is immediate (both used to be immediate). The first song's info appears and everything seems normal. When the next song plays, the playback time correctly resets and counts up again, but the song info does not update. It continues to show the first song's info for every song that plays after. Weirdly, when an advertisement plays, the playback time stays at 0:00 until another song starts, when it resumes counting again. After 20 songs and a few ads, still only the first song's info displays in the car.

Nothing I can do will update the song info. I've tried re-pairing the phone with the car. I've tried shutting down the app and restarting, manually skipping tracks back and forth, pausing/unpausing, all from both the car's interface and directly on the phone. The problem occurs every time I start the car. I have not tried using the old phone again because it will only play SoundCloud over wifi. I guess I could try creating a hotspot with the new phone to run the old phone but really that's not a solution.

Other music apps do not have this issue in my car. Spotify, and a music player app playing songs on the phone itself, both correctly update song info. Please advise.

Disclaimer: I'm a web and IoT engineer familiar with the Bluetooth protocol and Android development.

0 replies

Be the first to reply!

Reply