Question

How do I disable the autoplay on track embedded on my site ?

  • 16 March 2015
  • 5 replies
  • 5666 views

Hi
I'm a new user that experiencing a difficulty with the automatic play option.
I recently embedded a track on a post on my website (Wordpress, link below). The track automaticlly plays once I enter the post although the automatic play option in unmarked (in the Embedded tab).
How do I prevent the track from playing automatically.
The link to the post: http://horim-noladim.co.il/%D7%9C%D7%9E%D7%94-%D7%97%D7%A9%D7%95%D7%91-%D7%9C%D7%94%D7%AA%D7%97%D7%A...
Thanks in advance,
Michelle

5 replies

Userlevel 7
Badge +3
Hi there Michelle,

Thanks for posting on the help forum. I've taken a closer look into this for you. It looks like the auto-play option was still enabled for some reason.

Chrome has fantastic tools to troubleshoot this type of issues. Right-clicking on your page, I am able to choose "inspect element" to see the source code of your website. I cannot change things and save this (obviously), but it helps to investigate. As you can see in the following screenshot, the "auto_play" parameter is still enabled.

http://cl.ly/image/2Q3x3V0r2s05

Now, to change this, you can edit this to say "auto_play=false"

Here's something else you might want to do to simplify your WordPress editing in the future: if you're using WordPress.org, you can use plugins (as opposed to WordPress.com, which does not allow plugins).

If so, then I'd recommend to take a look at our shortcode plugin. Once installed, you can choose global settings, choose which type of embed you want to use per default (I recommend the visual embed or the regular html5 player) in the settings of the plugin.

On the next track you want to embed, choose the following format:


The plugin will automatically render this link into the player that you choose in the default settings of the plugin.

Hope this helps!

Cheers
Mathis
Hi Mathis

Thanks for your reply. I can see what you're saying on the "inspect element" but there is something strange. When I'm in Wordpress in the code on this page (where I embedded the soundcloud track) the autoplay shows false.
I attahced a screen shot of the page i hope it's clear enough. Can you understand why the "inspect element" shows one thing while the code on the page shows another ?
How do I fix this ?
Thanks
Michelle

Hi Mathis

Thanks for your reply. I can see what you're saying on the "inspect element" but there is something strange. When I'm in Wordpress in the code on this page (where I embedded the soundcloud track) the autoplay shows false.
I attahced a screen shot of the page i hope it's clear enough. Can you understand why the "inspect element" shows one thing while the code on the page shows another ?
How do I fix this ?
Thanks
Michelle

Hi
Would appreciate a reply to my post dated 24 March.
Thanks
Michelle
Userlevel 7
Badge +3
Hi Mathis

Thanks for your reply. I can see what you're saying on the "inspect element" but there is something strange. When I'm in Wordpress in the code on this page (where I embedded the soundcloud track) the autoplay shows false.
I attahced a screen shot of the page i hope it's clear enough. Can you understand why the "inspect element" shows one thing while the code on the page shows another ?
How do I fix this ?
Thanks
Michelle

Hi Michelle,

Sorry about not getting back to you on this one yet. Now, that is pretty strange indeed - it looks like whatever you're editing on the preview page does not get saved properly. The "Visual"-parameter is wrong as well (set to "true" when not the visual but the html5 embedded player is displayed).

Were you able to test the SoundCloud Shortcode plugin? How did that work? If this continues to not being saved, I'd recommend to reach out to WordPress to see if they can help with this.

Please let us know how this goes. Looking forward to hearing from you again.

Cheers
Mathis
Hi Mathis

Thanks for your reply. I can see what you're saying on the "inspect element" but there is something strange. When I'm in Wordpress in the code on this page (where I embedded the soundcloud track) the autoplay shows false.
I attahced a screen shot of the page i hope it's clear enough. Can you understand why the "inspect element" shows one thing while the code on the page shows another ?
How do I fix this ?
Thanks
Michelle

Hi

I've had the exact same problem when trying to embed a soundcloud track. That is the embedded track auto plays whenever my wordpress website loads even though I have not selected the autoplay option.

My fix for this was to use the soundcloud generated embed code but not use the "wordpress code" option.

I would appreciate it if soundcloud could please look into this issue.

Thanks.

Reply