Question

Mono/stereo issue??????


Hi, you seem to have updated your website, and since you have music streamed form your site only come out of one speaker. My hardware is not malfunctioning as another streaming service (spotify) works fine, wondering if the problem was on your end?

20 replies

Userlevel 7
Badge +3
Hi there Nyland81,

Thanks for reporting this. Hmm, super strange actually - we haven't received any other reports about this. Can you send over a track where this is the case for you? Even if it is all tracks, please send over one link that we can use as a test case.

Other then that, please make sure you apply the troubleshooting steps outlined here to either solve or further isolate the root cause.

One last question - are you using the on board sound card of your computer, or are you using an external sound interface? If so, what interface are you using?

Cheers
Mathis
I also have this problem. Just recently on soundcloud now every track has my speakers crackling like the speaker is blown, but any other streaming site or even my own downloaded music sounds perfectly fine. Very odd.
Userlevel 7
Badge +3
I also have this problem. Just recently on soundcloud now every track has my speakers crackling like the speaker is blown, but any other streaming site or even my own downloaded music sounds perfectly fine. Very odd.
Hi Michael,

Hmm, quite odd. It could be that your browser is not processing the audio signal properly. In order to test this, please try our basic troubleshooting steps to see if the root cause can be isolated, and if you're using an external audio interface, please try changing this to your internal audio card for the purpose of testing. If this helps, please check and see if there's a newer version of your browser and of Flash available, and also try and see if your firmware version for your audio interface is up to the latest version.

Let us know how it goes.

Cheers
Mathis
I have this problem too. I'm using a very current version of Firefox. Any suggestions would be helpful.
Thanks for taking the time to read this!
I just tried it in google chrome and the sound comes out of both speakers.
Userlevel 4
Badge
hi @Jimm Hickey what is the exact version of Firefox you are using? You can see it in the "about firefox" window. Also what operation system and version are you running?

Thanks
HI. I'm struggling with the same issue. Sound comes only out of the left speaker on Soundcloud. The Problem does not occur with any other services like YouTube or Twitter.
Currently I use Firefox 61.0.2 (64-Bit)on Arch Linux.

A current version of Chromium is not affected by this issue.

Best regards
I only have sound output in left speaker. I am running Firefox 62.0 (64 bit) on Linux Mint 18 (based on Ubuntu 16.04). Stereo output works fine in Chrome, other applications, and other websites in Firefox

Sound fails on every track I've tried so far, including https://soundcloud.com/ocremix/01-days-of-summer-v2-ktriton?in=ocremix/sets/radical-dreamers-thieves-of-fate.
if I stream Soundcloud songs from iPhone 8 to Chromecast it also drops out the right channel. So if a track has any instruments/audio panned to the right side of the stereo image, it can’t be heard. This problem does not occur when not casting and it’s been around for over a year I think. I’ve experienced it while streaming with BT too to BT Stereo speakers
Userlevel 4
Badge
Hey Olli I can't reproduce the problem. On our test device stereo works fine. Does stereo work on the TV when using other sources? Could you try the same chromecast in a different TV?

Is there a particular track that has the problem?

Thanks
I have a similar problem. Using firefox as browser, i get a mono sum of the track i´m listening to. It might only be one of the signals but distributed equally to both speakers. Stereo image collapsed. Lot of weird phase issues.
Problem does not occur when using other browsers.
Same problem here: Firefox 66.0.4 on Ubuntu 18.04; only the left channel is working on Firefox, working flawlessy with other browsers.
got the same problem on firefox since a few months; i just tried something who apparently worked: in about:config tab, i enabled accessibility.monoaudio.enable, restared firefox, disabled it; and the stereo is now better ...
Hi @Tom Jenkinson,

I'm also having this problem in Firefox 69 on Linux (Chrome works fine, and all other audio works fine in Firefox). liums suggestion to enable/disable mono output didn't work.

The audio is mostly panned left, right still works a little bit.

So I uploaded this Stereo Test YouTube video https://www.youtube.com/watch?v=6TWJaFD6R2s as a test here: https://soundcloud.com/nandryshak/stereo-left-and-right-stereo-sound-test

The left channel sounds normal, but when the "right" channel plays, it sounds like it's being summed to mono. Pretty wacky.
I also have this problem with firefox 69 on Linux - checked with pavucontrol, and soundcloud instead of stereo stream has 4 channels stream, but channels are front left, front center, front right, rear center, so front left and front center are playing instead of FL and FR, resulting in this mostly left panned sound

Great catch @Short Hand Proper Toes thanks!

@Tom Jenkinson, I wonder if this is something like the front end code creating 4 audio channels, and then assuming that there are only two audio streams, assign the left audio to the first channel and the right audio to the second. YouTube audio only makes 2 channels:

https://

Where as soundcloud makes 4, as shown in ShortHandProperToes's screen in the comment above. Also note the different AudioIPC Servers that the websites are using, not sure if it's that important. I've confirmed that the left side of the audio is in "front left", the right side is in "front center", and nothing is in "front right" or "rear center" by individually bringing down the faders in pavucontrol one by one.
Userlevel 4
Badge
Thanks for the investigation. It sounds like this is a bug in Firefox. There is more information on this ticket and I added a link to your investigation.

https://bugzilla.mozilla.org/show_bug.cgi?id=1434362
Great thanks Tom! That certainly sounds related. I will watch that bug ticket.
Hey!!
I'm facing the same issue on my car android device that the sound only comes from left speaker although it works fine with my Bluetooth, Radio and Youtube etc. Sometimes it start working fine but most of the time I face this problem.
Also multimedia steering buttons are also link with this problem. When the sound only come from left speaker I can't use the forward and backward button but when both speakers start working (as it happens rarely) then it also works fine.

Kindly fix it!!
Hey!!
I'm facing the same issue on my car android device that the sound only comes from left speaker although it works fine with my Bluetooth, Radio and Youtube etc. Sometimes it start working fine but most of the time I face this problem.
Also multimedia steering buttons are also link with this problem. When the sound only come from left speaker I can't use the forward and backward button but when both speakers start working (as it happens rarely) then it also works fine.

Kindly fix it!!

Tom Jenkinson

Reply