Question

Music randomly stops playing

  • 13 January 2015
  • 63 replies
  • 16969 views

On the desktop web interface, when I have a list of search results or a playlist it's supposed to go from one song to the next when the song ends, and at home this is what always happens, but here at work 4 out of 5 times it stops playing and the orange play/pause button changes to an animated ellipsis (three dots). I have to manually press the play button of the next song and that always works fine. I don't understand why the site randomly refuses to do this.

Chromium: 39.0.2171.65 (Developer Build) Ubuntu 14.04
Revision: b853bfefba0da840f4574eb3b5c7ad6e9b8573b5
OS: Linux
Blink :537.36 (@185325)
JavaScript: V8 3.29.88.17
Flash: 14.0.0.145
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/39.0.2171.65 Chrome/39.0.2171.65 Safari/537.36
Command Line: /usr/lib/chromium-browser/chromium-browser --ppapi-flash-path=/usr/lib/pepflashplugin-installer/libpepflashplayer.so --ppapi-flash-version=15.0.0.239 --ppapi-flash-path=/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so --ppapi-flash-version=14.0.0.145 --enable-pinch --flag-switches-begin --flag-switches-end

Extensions: none enabled during test

63 replies

Userlevel 7
Badge +3
Hi Zom-B,

Thanks for posting. Hmm, ok, let's see - With Linux, this can sometimes be tricky to investigate. Anyways, let's see what can be done.

First of all, I'd like to gather further details here.

a) Are you using one and the same laptop at home and at work, or are these separate computers?
b) Are you behind a firewall of some sort, or VPN / Proxy at work?
c) If so, and if you're using a work-exclusive device, any chance you can test it on a different internet connection?

Now, other then that, we're provided a set of basic maintenance steps, including clearing your cache and cookies, updating Flash, testing a different browser etc. The instructions can be found here. Please give these a try to see if this is working out.

Hope this helps to sort out, or at least to isolate the issue for you.

Cheers,
Mathis
Unfortunately, that's 3x no.

Cleared cookies, no change. Updating isn't possible without calling the administrator to my office so I'd rather not.

In another browser this problem doesn't occur, but it has other problems. Firefox scrolls this site slowly (1 frame per second) and opera has the worst user interface ever that I never want to use again.
Userlevel 7
Badge +3
Hey there again,

Hmpf - ok, well let's see - Now, the least we can tell is that it indeed seems to do with the system and / or internet connection at your work place.

Just to be sure - in Chromium, can you type chrome://extensions/ into the address field and press enter? This brings you to the list of installed extensions. Please disable them temporarily, restart the browser, then try again.

Also, can you try opening a new incognito window of Chromium to see if it happens in there, too?

Let me know how this goes.

Cheers,
Mathis
In the first post I wrote "Extensions: none enabled during test"

I tried the incognito window and it still hangs.

I'll be using FireFox for now. Apart from the slow scrolling, it works. FYI, it uses Shockwave Flash 11.2.202.429.
Userlevel 7
Badge +3
In the first post I wrote "Extensions: none enabled during test"

I tried the incognito window and it still hangs.

I'll be using FireFox for now. Apart from the slow scrolling, it works. FYI, it uses Shockwave Flash 11.2.202.429.

Hey Zom-B,

Thanks for following up. Argh, totally overlooked that note about the extensions, my bad. It becomes extremely difficult at some point to test such things from far away - also, I wasn't able to reproduce the issue from over here unfortunately (because then I could at least have a developer have a look and see if we can see any clues).

From what it sounds like, something seems to be blocking the audio engine when it is supposed to jump from one track to another - a firewall, antivirus software, or router setting of some sort.

I hope Firefox does the trick for you for now. If you happen to find the root cause, please feel free to let us know here.

Cheers,
Mathis
In the first post I wrote "Extensions: none enabled during test"

I tried the incognito window and it still hangs.

I'll be using FireFox for now. Apart from the slow scrolling, it works. FYI, it uses Shockwave Flash 11.2.202.429.

The admin has updated my PC, and Flash is still the same version (15.0.0.239), which I now assume is the newest.
I experience the same problem on my home network and on an eduroam wlan.

OS: Linux
Flash: 11.2.202.440
Browser: Mozilla Firefox 35.0.1u
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0

First experienced with the following addons: cookie-monster, ghostery and adblock. However I also experienced this issue with all of them disabled.
Userlevel 7
Badge +3
I experience the same problem on my home network and on an eduroam wlan.

OS: Linux
Flash: 11.2.202.440
Browser: Mozilla Firefox 35.0.1u
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0

First experienced with the following addons: cookie-monster, ghostery and adblock. However I also experienced this issue with all of them disabled.

Hi there,

Thanks for posting. Sorry to hear this is causing troubles for you. Can you let us know if you've tried our basic troubleshooting steps yet (clearing cache & cookies, testing a different browser, etc.) - is the issue similar in Chrome or a different browser?

It is quite difficult to diagnose the root cause of an issue, especially under Linux, as there are so many different software configurations these days, but I'm happy to take another look with you.

Looking forward to hearing from you.
Cheers,
Mathis
Hi, I am facing the same issue. At first was facing it on both my laptop plus mobile. After the update, the mobile seems to work fine. But mostly, its my laptop at work so not sure if mobile soundcloud has been fixed too.

The songs stop half way through and i have to pause/play after few minutes. This is so irritating. Colleagues usually think I am always on SoundCloud looking for songs when it is the other way.

I am using Firefox. Haven't changed my machine since 2-3 weeks (not using soundcloud from my personal laptop). My colleague is having no such issue (so it cannot be the internet connection too or the VPN). There is something wrong in my account.

Regards
Userlevel 7
Badge +3
Hi, I am facing the same issue. At first was facing it on both my laptop plus mobile. After the update, the mobile seems to work fine. But mostly, its my laptop at work so not sure if mobile soundcloud has been fixed too.

The songs stop half way through and i have to pause/play after few minutes. This is so irritating. Colleagues usually think I am always on SoundCloud looking for songs when it is the other way.

I am using Firefox. Haven't changed my machine since 2-3 weeks (not using soundcloud from my personal laptop). My colleague is having no such issue (so it cannot be the internet connection too or the VPN). There is something wrong in my account.

Regards

Hi Kiran,

Have you tried the troubleshooting steps outlined here? What happens if you use a different browser? Have you installed any add ons or extensions that might be getting in the way? Are you using the same computer (laptop) both at home and at work, i.e. could you test the same computer in different internet networks? These are the things I'd look into first.

From what I can see from my end, your account should be fine and not the culprit. Looking forward to hearing from you again. Let us know if further investigation is necessary.

Cheers
Hi, I am facing the same issue. At first was facing it on both my laptop plus mobile. After the update, the mobile seems to work fine. But mostly, its my laptop at work so not sure if mobile soundcloud has been fixed too.

The songs stop half way through and i have to pause/play after few minutes. This is so irritating. Colleagues usually think I am always on SoundCloud looking for songs when it is the other way.

I am using Firefox. Haven't changed my machine since 2-3 weeks (not using soundcloud from my personal laptop). My colleague is having no such issue (so it cannot be the internet connection too or the VPN). There is something wrong in my account.

Regards

Happens to me too. On my MacBook + on my IPad. It seem to happen whenever the device screen turns off. On touch of the mouse pad or sliding the screen on the IPad and the Song streams again. It also appears that on my IPad it happens after every song, if I am not actively using the IPad.
I tried on Safari (IPad) + Chrome (MacBook) - both have issues. Any tips other than clearing the cache?
Hi, I am facing the same issue. At first was facing it on both my laptop plus mobile. After the update, the mobile seems to work fine. But mostly, its my laptop at work so not sure if mobile soundcloud has been fixed too.

The songs stop half way through and i have to pause/play after few minutes. This is so irritating. Colleagues usually think I am always on SoundCloud looking for songs when it is the other way.

I am using Firefox. Haven't changed my machine since 2-3 weeks (not using soundcloud from my personal laptop). My colleague is having no such issue (so it cannot be the internet connection too or the VPN). There is something wrong in my account.

Regards

I'm having the same problem. It only just recently started doing it. I have a macbook retina with OSX Yosemite, google chrome, all up to date. It's weird. I didn't think i touched any settings. It just happened recently. Very annoying
Hi, I am facing the same issue. At first was facing it on both my laptop plus mobile. After the update, the mobile seems to work fine. But mostly, its my laptop at work so not sure if mobile soundcloud has been fixed too.

The songs stop half way through and i have to pause/play after few minutes. This is so irritating. Colleagues usually think I am always on SoundCloud looking for songs when it is the other way.

I am using Firefox. Haven't changed my machine since 2-3 weeks (not using soundcloud from my personal laptop). My colleague is having no such issue (so it cannot be the internet connection too or the VPN). There is something wrong in my account.

Regards

It happens to me also 😞 soundcloud should fix this problem!
Hi, I am facing the same issue. At first was facing it on both my laptop plus mobile. After the update, the mobile seems to work fine. But mostly, its my laptop at work so not sure if mobile soundcloud has been fixed too.

The songs stop half way through and i have to pause/play after few minutes. This is so irritating. Colleagues usually think I am always on SoundCloud looking for songs when it is the other way.

I am using Firefox. Haven't changed my machine since 2-3 weeks (not using soundcloud from my personal laptop). My colleague is having no such issue (so it cannot be the internet connection too or the VPN). There is something wrong in my account.

Regards

Hi, similar to the first post this has also been occurring quite frequently, if not all the time, and it is very frustrating.

Why would I want to listen to only a single track? Please resolve your player issues.

-Windows,
-Using Chrome
-No extensions.

Please fix this, like really now ffs. it is not "Solved" FIX YOUR SHIT MAN!
Hey there again,

Hmpf - ok, well let's see - Now, the least we can tell is that it indeed seems to do with the system and / or internet connection at your work place.

Just to be sure - in Chromium, can you type chrome://extensions/ into the address field and press enter? This brings you to the list of installed extensions. Please disable them temporarily, restart the browser, then try again.

Also, can you try opening a new incognito window of Chromium to see if it happens in there, too?

Let me know how this goes.

Cheers,
Mathis

Hi, similar to the first post this has also been occurring quite frequently, if not all the time, and it is very frustrating.

Why would I want to listen to only a single track? Please resolve your player issues.

-Windows,
-Using Chrome
-No extensions.

Please fix this, like really now ffs. it is not "Solved" FIX YOUR SHIT MAN!
Hi, similar to the first post this has also been occurring quite frequently, if not all the time, and it is very frustrating.

Why would I want to listen to only a single track? Please resolve your player issues.

-Windows,
-Using Chrome
-No extensions.

Please fix this, like really now ffs. it is not "Solved" FIX YOUR SHIT MAN!
Same issue here. Windows, Chrome, completely new build with all the updates. Seems to happen when I go to a different tab within Chrome while Soundcloud is playing. If I'm not actually "viewing" the Soundcloud tab, it stops playing. This seems to be a really easy fix as I would hate to think Soundcloud is forcing listeners to view their website when the music stops playing.
I'm having the same issue and it's driving me nutso! I haven't done anything differently to settings or browser extensions. The problem exists for me on both windows and mac. It's most certainly a SoundCloud issue.
The same here, very annoying problem. Happens with both phone and computer.

My configs
Windows
Chrome
Just the naive settings
Can't listen to a set without it stopping intermittently. So frustrating!

This has gotten worse in the past few weeks to the point of not even bothering to use Soundcloud anymore :*(

My config:

Windows 10
Chrome
Same problem. Windows 7, this happens on both Firefox and Chrome. Some tracks play smoothly but many will halt at least once and it's gotten to the point where some track won't load at all at times.
MacBook Pro / 10.10.5 / 8GB RAM / i7 / Firefox 42.0

1. Cleared all history, cookies, info
2. Updated Flash to the latest version
3. Updated Firefox to the latest version
4. 60mb/s business class internet service

Player stops playing randomly then works fine after I hit the "play" button. Happens within the first 30 seconds of the song with nearly every song. Basically, can't walk away from my system without having to hit the play button over and over and over and over and over... FYI - not even the ADs finish playing.

Looked up the problem on your forum and elsewhere online. Haven't found a single solution - nothing in this thread has worked either.

Thoughts?
Yup same problem Windows 10 , Google Chrome
I can confirm this behave, very frustrated, a few days ago click the play button and every track was playing but now after 2-3 tracks stops without error must to click manual the play button
Is anyone from Soundcloud looking at this thread?

Reply