Answered

My "Home" page has been blank...


My "Home" page
https://soundcloud.com/discover
has been blank in the browser on MacOS...

I'm in the same trouble even on the other machine and/or browsers.

Could somebody please teach me how to fix it?
icon

Best answer by Icoste 10 December 2018, 00:08

I found the fix for this bug: In the Parameters (right-top corner) > Analytics of SoundCloud, say "Yes" to "Help us enhance SoundCloud bla bla bla". It will prevent the JavaScript from crashing during the upload, and the HomePage will work again.

Here's how I found about that bug:

I opened my Chrome console, I saw errors and I googled for the error messages: it had to do with a vue.js extension that gets buggy when one blocks analytics scripts with a Chrome extension. So, I tried disabling my extensions (didn't work), disabling my Kaspersky (didn't work either) and then I checked this button on my parameters page and VOILÀ, the errors in the Chrome console disappeared!

It's a stupid thing: we HAVE to enable analytics on SoundCloud to upload our stuff. Could the staff work on this please? It's really too bad 😕
View original

This topic has been closed for comments

12 replies

Same here. And processing of uploaded tracks doesn't work either.
I have the same problem.Uploading track via the soundcloud app does work btw.After uploading you can still modify the track in the soundcloud browser (laptop).
Thank you for the comments. Indeed Upload procedure is not working...
And still no news from the staff or some entry in the Status blog?
Two big problems since days (Discover page, Upload processing fails) and no one from the staff seems to care.

hearthis.at, btw.
Same here! Manjaro/Arch Linux, latest patch level. FF 63.0.3 (x64) discover page empty for days now. I need my weekly playlist! 😢
Now, my track, which uploaded yesterday, has been processed... In order to check if the issue is fixed, I posted another track. but... the procedure page is still showing "We are processing your track for playback…" more than 10 minutes...
Userlevel 1
I found the fix for this bug: In the Parameters (right-top corner) > Analytics of SoundCloud, say "Yes" to "Help us enhance SoundCloud bla bla bla". It will prevent the JavaScript from crashing during the upload, and the HomePage will work again.

Here's how I found about that bug:

I opened my Chrome console, I saw errors and I googled for the error messages: it had to do with a vue.js extension that gets buggy when one blocks analytics scripts with a Chrome extension. So, I tried disabling my extensions (didn't work), disabling my Kaspersky (didn't work either) and then I checked this button on my parameters page and VOILÀ, the errors in the Chrome console disappeared!

It's a stupid thing: we HAVE to enable analytics on SoundCloud to upload our stuff. Could the staff work on this please? It's really too bad 😕
Wow! It has been fixed right now!!
after "Settings> Analytics> Yes!".

Thank you Icoste - san!!!
Userlevel 1
Or you could "remove" the broken and useless GA stuff: https://community.soundcloud.com/upload-manage-230060/workaround-for-stacked-processing-7424449
Thank you DukeSniper - san!
Userlevel 1
I forgot to tell because it was super late over here in France when I posted my fix, but there is a step I didn't specify:

  • Once you have turned the "Help us unhance SoundCloud blabla" to "Yes" in the "Analytics" parameters, cancel your upload and reload the upload page or the home page so that the JavaScript gets refreshed; else the error will still be present.