Answered

Since today 2018/01/15 music only plays in one speaker

  • 15 January 2018
  • 72 replies
  • 6439 views

This is only happening under Firefox, Chrome works fine.

I checked Youtube and everywhere else and they play fine.

Only Soundcloud has this problem, all music is only coming through one speaker, making it unusable under Firefox.
icon

Best answer by SevenKnights 20 April 2019, 22:03

For anyone else having the same issue.

It's not Firefox, it's not Chrome. It's Pulseaudio.

In /etc/pulse/daemon.conf set:
code:
enable-lfe-remixing = yes


Restart Pulseaudio:
code:
pulseaudio -k && pulseaudio --start


Soundcloud and some old youtube songs will work again after this.
View original

72 replies

Userlevel 4
Badge
hey @Sev

- What version of firefox are you using?
- What operating system and version are you using?
- Are you listening with headphones or laptop speakers?

Thanks
- I'm using Firefox 57.0.4 (64 bits)
- I'm using ArchLinux updated to latest.
- It's a 5.1 speaker setup.

Soundcloud is the only website doing this.

It works fine under Chrome, I'm guessing API misusage.

It worked the day before. I didn't touch the OS.
Userlevel 4
Badge
@SevenKnights thanks. Please could you try updating to firefox version 58?
57.04 is the latest release from January 4th. 58 is the beta version. That being said, I've updated to 58 and it does not solve the loss of surround stereo that occurred in Soundcloud on Firefox in the last few days. Mixcloud and YouTube and all other media sites continue to play in 7.1 stereo, whereas Soundcloud only plays in 2.0 and a half... stereo with really weak bass. This is a serious problem.
Same here. Firefox 57.04 on Ubuntu 16.04.3. Sound only over left speaker. Mixcloud and local music player work as expected at full blast.
Userlevel 4
Badge
@DJ Charts @d.brot thanks for checking. Does this still happen when logged out in an incognito window?
@DJ Charts @d.brot thanks for checking. Does this still happen when logged out in an incognito window?

It does indeed work in an incognito window! 7.1 stereo surround is working perfectly. Why is that?
Userlevel 4
Badge
We are gradually rolling out an update at the moment. It looks like it might have caused a problem for Firefox users with surround sound from the reports here, so have stopped it for now.

Please can you refresh the page in Firefox and try again whilst logged in?

Thanks
Yes, stereo works in an incognito window! Wow, good hint.

So I cleared all soundcloud.com cookies and now sound is back full on again 😃

Thanks for your help! @DJ Charts @Tom Jenkinson
Please can you refresh the page in Firefox and try again whilst logged in?

Yep, a refresh has restored surround functionality. Thank you very much!
Userlevel 4
Badge
@DJ Charts @d.brot

Please can you try playing the audio on the following page in Firefox? Does this work in both speakers or just one?

Thanks

https://jsbin.com/mekazun
@DJ Charts @d.brot

Please can you try playing the audio on the following page in Firefox? Does this work in both speakers or just one?


Plays in stereo here, but not surround stereo. Sound only comes out left/right speakers with weak bass. I have a creative 7.1 setup.
Userlevel 4
Badge
@DJ Charts so the same page in chrome plays from all the speakers?

Is this the same problem you were having a few days ago on soundcloud.com?

@d.brot could you try loading the page above too? You said you only heard the audio in the left speaker which I think is a different problem to what @DJ Charts was having.
@DJ Charts so the same page in chrome plays from all the speakers?

Is this the same problem you were having a few days ago on soundcloud.com?


Chrome (and Opera) has never played out of all the speakers, with any media site. Firefox does work with all media sites and was the only browser that did for a long time. Oddly enough, Microsoft Edge did work the other day out of all speakers, even when Firefox wasn't working.

Yes, the same problem as the other day with the example you sent. Meanwhile the main site continues to work as expected.
Userlevel 4
Badge
hey @DJ Charts what OS are you using, and what audio hardware?

Please could you try changing this setting and then loading that test page again?

https://superuser.com/a/339513/114938

Thanks!
Hello, why was I banned?

This thread is the only thing I made on this site and my first post got deleted.

I came back to say that clearing the cookies fixed my issue only to find I was banned for some reason.

Anyhow... I fixed my issue by deleting the cookies.
Userlevel 4
Badge
@Throwaway4Seven thanks for the update. I'm not sure what happened the topic disappeared for some time and has now come back again.
It appears that refreshing the page after loging in with my original account breaks the settings again and it goes back to mono channel.

Is something wrong with my original account? It doesn't happen in this one. I wouldn't like to lose all my favorites.
Userlevel 4
Badge
@Throwaway4Seven do you have the same problem on https://jsbin.com/mekazun ?

Thanks
Yes, there is only mono and in only one speaker with that page.
Userlevel 4
Badge
ok. @Throwaway4Seven what browser version and OS are you using? Does that test page have the same problem in other browsers?

Thanks
- I'm using Firefox 57.0.4 (64 bits)
- I'm using ArchLinux updated to latest.
- It's a 5.1 speaker setup.

Soundcloud is the only website doing this.

It works fine under Chrome, I'm guessing API misusage.

It worked the day before. I didn't touch the OS.


Can you unban me? It's getting confusing for both.

Chrome plays it correctly.
Userlevel 4
Badge
thanks @thraisyyy sorry there seems to be a glitch somewhere but we will try and get your other account unbanned.

I am wondering if maybe your speaker/routing is configured incorrectly. Your right speaker could be configured as the centre one and this could cause this problem, for example.

Please could you check with something like https://www.dolby.com/us/en/guide/test-tones.html

the speaker-test command might also be helpful: https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture

Thanks!

@d.brot could you try loading the page above too? You said you only heard the audio in the left speaker which I think is a different problem to what @DJ Charts was having.


I loaded the page and it played only on the left speaker.

Right now, I had the problem again. Sound only on left speakers on soundcloud.com. A CTRL-r did not work, but as stated above, clearing all soundcloud.com cookies solved my problem.
Userlevel 4
Badge
Hey @d.brot how many speakers do you have? It sounds like it could be a configuration issue, or maybe a bug in Firefox.

https://help.ubuntu.com/community/SurroundSound might help with debugging.

Reply