Answered

Since today 2018/01/15 music only plays in one speaker

  • 15 January 2018
  • 72 replies
  • 6738 views


Show first post

72 replies

thanks @thraisyyy sorry there seems to be a glitch somewhere but we will try and get your other account unbanned.

I am wondering if maybe your speaker/routing is configured incorrectly. Your right speaker could be configured as the centre one and this could cause this problem, for example.

Please could you check with something like https://www.dolby.com/us/en/guide/test-tones.html

the speaker-test command might also be helpful: https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture

Thanks!


My speakers work correctly, all other applications work correctly.

It just happens on Soundcloud when I'm already loged in.

If I logout then login the issue is fixed until the next time I reload the page. It's merely an annoyance now that I know the workaround.
Userlevel 4
Badge
@Throwaway4Seven Ok. If you are sure they are all mapped correctly then it looks like a bug (with WebAudio) in Firefox on ArchLinux. I will open a ticket in Firefox's bug tracker.
Solution if you have no surround sound:
I had the same problem with Firefox 58, after I upgraded from Win7 to Win10 yesterday. The incognito mode pointed me into the right direction. It's the Ani-Tracking feature of the new Firefox which causes this problem, at least was this the cause for me. Just click on the shield-symbol in the URL bar and deactivate the Anti-Tracking protection for the Soundcloud site. After this I had surround sound again. I hope this helps somebody of you.
Have absolutely same issue.

Symptoms: Playback only on left channel.

How to reproduce:
1) Install gentoo x64
2) Install any DE (for example, kde)
3) Install pulseaudio
4) Install firefox-bin
5) login to soundcloud

Hardware:
1) 00:1f.3 Audio device: Intel Corporation 200 Series PCH HD Audio (intel HDA)
2) 5.1 surround system (connected)

Configuration:
1) pulseaudio are configured by default (no ressampling or whatever). Vanilla gentoo configuration
2) pulseaudio profile are set to 5.1 sound
2) Kernel buffer set to default param (2k page)

All system sounds are work fine. Even, if I open: http://www.audiocheck.net/audiotests_stereo.php -> it correctly reproduce audio (I think, hense used html5 for reproduce audio).

I don't know, how soundclound are streaming audio (RTP? Dummu HTTP?), but defensively something goes wrong in case of FF.
(P.S. Also, I fully removed FF configuration. But still issue exist).
# When you click "play" on any sound, soundcloud returns mpeg playlist with streams
# Then some magic

As sound are still plays in chromium, I think, problem should be in Soundcloud player (hehey, hello to dummy javascript).
So, I sure, that problem in JS player at soundcloud.
Ah, see, soundcloud send sound by "parts" and with help of javascript glue final playback buffer and then play it. Looks, that some logic, that responsible for buffer processing (or maybe, playback) just ignore one channel
+ @Tom Jenkinson as looks like he is developer, maybe my information will help to process this ticket
By the way, my firefox also doesn't play: https://download.dolby.com/us/en/test-tones/dolby-test-tones_5_1_2.mp4
Userlevel 4
Badge
@Feniks Gordon Freeman doesn't play that at all, or only plays from the left speaker?

Also what does https://jsbin.com/mekazun sound like?

Thanks
@Tom It doesn't play at all. No sound (if I open mp4 on ff). If I download it and play with vlc or mplayer -> everything works and correct.

> Also what does https://jsbin.com/mekazun sound like?
Yey. only left channel. In FF console it prints "6", so JS and FF detected correctly number of channels.

As I understand from JS on https://jsbin.com/mekazun, it creates WebAudio context and just try to play it.
Just googled first example with WebAudio -> https://www.html5rocks.com/en/tutorials/webaudio/intro/ it have absolutely same issue.

Summary: in Firefox 58 for Linux x64 systems for 5.1 and 7.1 broken. Only Left channel are played.
But now question -> how to fix that? Fill bug at mozilla?
@Tom

Take a look: https://developer.mozilla.org/en-US/Firefox/Releases/54 in WebAPI section. In 54 release, FF turned on Surround playback. In prev. version, FF always play sound in stereo mode. But after release 54, it tries to play in surround mode. And here it is a bug.
Userlevel 4
Badge
@Feniks Gordon Freeman great debugging!

We have this ticket now, but it's slightly different because it's related to the sound not being upmixed to surround sound and only coming out of front left and right with no bass, on windows.

https://bugzilla.mozilla.org/show_bug.cgi?id=1434362

Please could you create a new ticket for your case, with the messages you posted here (the link to the jsbin and webaudio tutorial)? https://bugzilla.mozilla.org/show_bug.cgi?id=1323659 sounds like a good ticket to update with a link to this new one too.

This is where to create a ticket: https://bugzilla.mozilla.org/enter_bug.cgi

Otherwise if you prefer I can create a ticket next week.

Thanks!
@Tom I filled a bug at FF bugtracker: https://bugzilla.mozilla.org/show_bug.cgi?id=1435598 . Thanks
Userlevel 4
Badge
@Feniks Gordon Freeman that's perfect thanks. I will keep an eye on it.
It seems the logout/login workaround no longer works. I need to clear the cookies with ctrl+shift+c storage tab.

I had the anti tracking disabled so I never got the option.

You guys are on the right track already though. It' is a Firefox Linux x64 bug.

I'm unbanned, yay!
Firefox Linux 58 breaks the workaround. Clearing cookies no longer fixes the channels.
I'm on firefox 58.0.2 on Ubuntu 16.04.

Left Chanel only. 4 speakers have no sound front right has very low volume, approx 1% of front left.
Tried in chromium, works fine on all speakers.
Never had an account. Created one so I could leave feedback.
Private window same problem. Just won't work in firefox
Userlevel 4
Badge
@Mongrel Shark thanks for reporting sorry you have the problem. This is quite likely a Firefox bug (below), which will hopefully be fixed soon.

https://bugzilla.mozilla.org/show_bug.cgi?id=1434362
Hello from me too!

I'm on Ubuntu 16.04 64bit and using Firefox 58.0.2. I have slightly different problem than the rest. I'm using stereo playback and have signal in both channels, however the signal in the left channel is noticeably louder than the right channel. I'm feeding the signal from my soundcard to a mixer and there I can easily see the peakmeters on both channel are different (about 15dB which is a lot). Again, this happens only in firefox (chromium is ok) and only on soundcloud (youtube and desktop players are all ok).
Userlevel 4
Badge
@skrech interesting thanks. I suggest we wait until the Firefox bug above has been fixed, and then if this problem still exists we can possibly create another ticket and look into it further.
@Mongrel Shark thanks for reporting sorry you have the problem. This is quite likely a Firefox bug (below), which will hopefully be fixed soon.

https://bugzilla.mozilla.org/show_bug.cgi?id=1434362


Did you read my reply to that ticket Tom? The problem really only exists with Soundcloud. I do not believe it's an issue with Firefox as all other media sites I visit upmix perfectly fine.
Userlevel 4
Badge
@DJ Charts yes. I think it still might be this problem though because most media sites do not currently use web audio.
@DJ Charts yes. I think it still might be this problem though because most media sites do not currently use web audio.

I see, thanks for the explanation.
I thought I was the only person with this issue. Running Linux Mint 18.2 on Firefox 57 (64-bit) and only SoundCloud plays in my left channel. I've switched devices from HDMI to aux output, cleared cookies, logged in/out of SoundCloud and the issue still occurs.

Does anyone know of a workaround in about:config of Firefox?

Reply