Question

Can't enter release date for my album


Hi there, I've just (attempted to) create my first album. I entered in all the information necessary, including the release date for it. However, every time I try to click "Save", it always says I need to fill out the release date even though I already did. I tried clicking the calendar icon on the side but it doesn't work.

6 replies

Having the same problem, did you ever figure it out? If so, what was it?
Userlevel 7
Badge +3
Hi there,

Sorry to hear that. I've had another user report this recently and have passed on the feedback to our engineers.

If this issue persists for you, can you let us know the track / playlist / album in question and the release date you're going for?
Having the same problem
Yes please. Having the very same problem.
Can't enter release date for an older album.
Newer release dates, no problem. But that's not what I want.
Please Help.

All best
I changed computer and it worked. It wouldn't let me do it from my MacBook Pro laptop but allowed me on my Mac Pro desktop. I used Safari on both.

Maybe try a different computer if you can.
Having the same problem, the album is called The First I want to release 20/4/19

Reply