Question

Player NOT Autoplaying


I'm embedding the player into my website and it will not autoplay. Is this a bug?

I have already...
1) Checked the "enable autoplay box"
2) Checked the code auto_play=true

We have embedded many Soundcloud players into our site and now none of them are Autoplaying...

Here's an example of one of the players:
https://www.chadcheese.com/single-post/2018/05/02/Interview-Tony-Lee-of-SHRM---Uncommonco-Exclusive

3 replies

Does anyone from Soundcloud actually check these tickets out?
Userlevel 7
Badge +3
Hi Chad,

Just came across your topic. We're trying to moderate and help wherever possible, but cannot always catch it all.

I've taken a look at your website - great that you included the URL so I could start investigating right away.

I took your embed code and went to http://htmledit.squarefree.com/, which is a simple website to test & run basic html code without the need to save changes all the time. Pasting the code you used on your website actually does automatically start playing the track. Thus, I can only assume that there is some code on your website that's interfering with the embedded player.

I did some further digging - opened the console in Chrome and reloaded your website:



As you can see on the right hand side, Chrome seems to be blocking the audio content. Luckily, they even provide a link where this is explained in further detail. Here you go: https://developers.google.com/web/updates/2017/09/autoplay-policy-changes#webaudio

Hope this helps 🙂

All the best & happy embedding
Mathis
Mathis wrote:


As you can see on the right hand side, Chrome seems to be blocking the audio content. Luckily, they even provide a link where this is explained in further detail. Here you go: https://developers.google.com/web/updates/2017/09/autoplay-policy-changes#webaudio



Will Soundcloud fix this so player will autoplay in Chrome?

Reply