Question

Artist image appearing behind waveform.

  • 24 July 2019
  • 1 reply
  • 39 views

Hi All,

We're having trouble with the artist image appearing behind the waveform when it's embedded, the image becomes pixelated etc but we also don't want it to be there.

Is there an option to have have just a black background, can this be added to the code?



Thanks for your help.

1 reply

Userlevel 7
Badge +3
Hey there,

Hmm, it looks like you're embedding the "Visual" embedded player. Rather than that, you could use the regular embedded player which shows a smaller version of the artwork on the left hand side. Or, you could even hide the small artwork:

< iframe width="100%" height="166" scrolling="no" frameborder="no" allow="autoplay" src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/646130802%3Fsecret_token%3Ds-iGvWx&color=%23ff5500&auto_play=false&hide_related=false&show_comments=true&show_user=true&show_reposts=false&show_teaser=true&show_artwork=false">

(make sure you remove the space between the first < and the term iframe if you're using this embed code)

This won't turn the background black though. Another option here would be to use the mini-player. Note that the background of the mini-player is actually transparent - i.e. if you choose "dark" as the background, the font of the artist and title will invert to white to make sure it is visible on a dark background.

< iframe width="100%" height="20" scrolling="no" frameborder="no" allow="autoplay" src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/646130802%3Fsecret_token%3Ds-iGvWx&color=%23ff5500&inverse=true&auto_play=false&show_user=true">

(make sure you remove the space between the first < and the term iframe if you're using this embed code)

The different embedded players and how to use them are outlined here on our Help Center: https://help.soundcloud.com/hc/en-us/articles/115003453587-Embedded-players

Phew, loads of info, I hope it's clear to understand. Happy embedding 🙂

Reply