Question

Artwork not being displayed


I uploaded a track and attached some album artwork with it but when i share the link to the track on twitter it shows my profile picture and not the artwork for the track. How do I fix this problem?

20 replies

Userlevel 7
Badge +3
Hi there jp_flows,

Thank you for writing in about this. I'm afraid this is due to how Twitter caches information about your tracks on their end - when you shared that track, it probably pulled the info from their caches. However, it looks like it has refreshed by now - I've just tweeted your track, and the track artwork is showing up properly.

If you share it again, you should be able to see the appropriate artwork. Our developers are aware of this happening and are looking into ways to improve this in the future.

On a different note - thank you so much for that piece of music! Totally hits my personal taste, I love it! 🙂

Cheers
Mathis
My artwork wont even upload to my track at all. whats the deal? Says error uploading picture. ive tried several different photo and nothing. wont even let me change my profile pic now.
Userlevel 1
Actually, using a different browser worked for me. Had to try Internet Explorer
It seems i'm having the same issue as jp, below me here..its something that's kind of been an on going issue..The album or track artwork does not show up when sharing to facebook/others,and instead, my profile artwork is whats being shown..
Userlevel 7
Badge +3
Dj Suess wrote:

It seems i'm having the same issue as jp, below me here..its something that's kind of been an on going issue..The album or track artwork does not show up when sharing to facebook/others,and instead, my profile artwork is whats being shown..


Hey DjSuess,

This should now be A-OK for your track "Shaolin replicant" (was that the track in question?) - I've used Facebook's debugging tool to get Facebook's cache cleaned up. This is where the issue is rooted actually - other social networks like Facebook and Twitter are caching data, which can however easily be outdated. We have little control over that, yet our developers are looking for ways to improve this overall in the future.

Hope this helps to shed some light on the issue.

Cheers
Mathis
Userlevel 1
Dj Suess wrote:

It seems i'm having the same issue as jp, below me here..its something that's kind of been an on going issue..The album or track artwork does not show up when sharing to facebook/others,and instead, my profile artwork is whats being shown..


Hello
I have been having the same problems, no matter what i try when i try to share the link to Facebook my profile picture comes up , i have debugges i have deleted cookies and cache everything i have found on google telling me how to fix this and nothing, PLEASE i need help as i really want to advertise my music on facebook with the right artwork

Any help would be amazing Thank you

https://soundcloud.com/ito-musica/jan-satorras-hippymetal

https://soundcloud.com/ito-musica/jan-satorras-thunderhippy
Dj Suess wrote:

It seems i'm having the same issue as jp, below me here..its something that's kind of been an on going issue..The album or track artwork does not show up when sharing to facebook/others,and instead, my profile artwork is whats being shown..


me too ! please help me with this, instead of the artwork i uploaded ,my old profile pictures appears and it is really annoying . artist's work should be represented properly .
https://soundcloud.com/stefan-marin/stefan-marin-memories-original-edit
Userlevel 1
Dj Suess wrote:

It seems i'm having the same issue as jp, below me here..its something that's kind of been an on going issue..The album or track artwork does not show up when sharing to facebook/others,and instead, my profile artwork is whats being shown..


Ok i will help if i can, Found this out after so give it a try and it should work.

Copy your link to the debug website https://developers.facebook.com/tools/debug/

Add your link to the debugger and click debug
"Now the important part" on the next page after hitting debug, make sure that you hit the "fetch new scrape information" BEFORE you copy and paste the link to FB , This is the most important part but you wont find it stated on most sites. Once you have fetched the new scrape information copy and paste to FB and your album artwork should show up ok.

I hope this helps
Dj Suess wrote:

It seems i'm having the same issue as jp, below me here..its something that's kind of been an on going issue..The album or track artwork does not show up when sharing to facebook/others,and instead, my profile artwork is whats being shown..


I try the debugger and there's still a problem.. this is really annoying, artwork is important. especially after upgrading.
hello i have changed and uploaded a new imagine for my music, but eveytime i copy and paste my link on to a site, the old image keep appearing as my album cover. can someone advise please thanks
Dj Suess wrote:

It seems i'm having the same issue as jp, below me here..its something that's kind of been an on going issue..The album or track artwork does not show up when sharing to facebook/others,and instead, my profile artwork is whats being shown..


hello when i share my track on facebook the old album art comes , its not going only my track is spreadlove ep1 and that drunk photo of me comes so i cant share on facebook till now please help.
Dj mojgan wrote:

hello i have changed and uploaded a new imagine for my music, but eveytime i copy and paste my link on to a site, the old image keep appearing as my album cover. can someone advise please thanks


same problem here , please help us
Dj mojgan wrote:

hello i have changed and uploaded a new imagine for my music, but eveytime i copy and paste my link on to a site, the old image keep appearing as my album cover. can someone advise please thanks


similar here. artwork meets all upload requirements, says it took, appears in preview, then: murky blackness. two pieces in a row.

please help, and thank you.
Userlevel 2
I am experiencing this problem when I share my tracks to facebook. For example this track:

https://soundcloud.com/westhillsfriends/mike-huber-on-hunger-and-risk

when uploaded to FB automatically changes the track image to our profile picture. I ran the FB debugger and it did nothing to help.
I've been having issues when uploading the song artwork...image does not show or even load. I've send the same MP3 and art file to a mate who lives in UK and Asia and works just fine. So I'm thinking this could be a regional issue? Its very very annoying..
Its showing old artwork for this song https://soundcloud.com/therealdjcortez/416-tn-on-my-way-prod-by-tntxd can you guys please fix this asap
Userlevel 2
https://www.soundcloudcommunity.com/soundcloud/topics/how-to-add-an-art-cover-for-a-track-instead-of-having-a-profile-image My issue is only with soundcloud, I just wanted to add a background picture, not the profile picture, like I used a few months ago like this one:- https://soundcloud.com/shantnakashian/jean-michel-jarre-oxygen-part-2-remixed-by-shant-nakashian
Dj Suess wrote:

It seems i'm having the same issue as jp, below me here..its something that's kind of been an on going issue..The album or track artwork does not show up when sharing to facebook/others,and instead, my profile artwork is whats being shown..


is there a link like this for twitter?
Mathis wrote:

Hi there jp_flows,

Thank you for writing in about this. I'm afraid this is due to how Twitter caches information about your tracks on their end - when you shared that track, it probably pulled the info from their caches. However, it looks like it has refreshed by now - I've just tweeted your track, and the track artwork is showing up properly.

If you share it again, you should be able to see the appropriate artwork. Our developers are aware of this happening and are looking into ways to improve this in the future.

On a different note - thank you so much for that piece of music! Totally hits my personal taste, I love it! 🙂

Cheers
Mathis


Just uploaded a song this morning and I got the same problem. When I try to share the link to the track on Twitter or Facebook, it shows my profile picture and not the artwork for the track and when you press play on those two sites, It wont play, but it will play on Soundcloud. What do I do?
Hi! I uploaded a song called ‘People’ on my account with its own cover art. The song is displaying my old profile photo on mobile devices. Is there a way to refresh my upload so that the track displays its cover art instead of my profile picture? thanks in advance for your help

Reply