Question

CLASSIC EMBED doesn't work anymore !!!


Userlevel 1
Hello
HELP!!! My WordPress website functioned all right so far, with Soundcloud CLASSIC embed tracks. The all architecture of the site relies on these Classic embed aspect.
For an hour or two, the VISUAL embed, of ALL my tracks, appears — INSTEAD of the CLASSIC one. It's horrible !!!
How come ??? Can you fix that ?

38 replies

Userlevel 1
I suspect Soundcloud has suddenly changed its logic basis. Whereas Classic Embed was the rule and Visual the new thing, they wanted to clarify but forgot to add a code information in the Classic code line...
Same thing.... Awfull !! What _s happening !?
Userlevel 7
Badge +3
Hi you two,

May I ask you to send over the links to your WordPress pages? Also, just to clarify - by "Classic Embed", were you referring to the Flash-based embed, or the regular HTML5 embedded player?

Cheers
Mathis
Yes HTML 5 (you call it "classic"...)
Userlevel 7
Badge +3
Yes HTML 5 (you call it "classic"...)
Hey, sorry about the confusion. In this article on our help center, we introduce the different embed options we have - The Visual player, The HTML5 player, and the Mini player. With this being said, can you confirm that you're referring to the HTML5 player? May I ask where you've seen us referring to it as "Classic"?

Also, please send over the link to your WordPress website so we can investigate further.

Cheers
Mathis
Userlevel 1
Hi
I spent all night repairing my WordPress sites....
The thing is that, in order to have the HTML 5 aspect (call it Classic, Regular, or whatever...) you need NOW to add in your line code (the one you copy to paste it your website) the instruction : "&visual=false".
Without this instruction, the Visual aspect is the one directly used, even if you choose the HTML 5 option.
This was not the case until yesterday...
Someone somewhere has changed something !!!
Hours lost and may be...money...
Userlevel 1
Talismen is right : when you're over the HTML 5 option, a yellow strip with "Classic embed" appears...
Userlevel 7
Badge +3
Hi
I spent all night repairing my WordPress sites....
The thing is that, in order to have the HTML 5 aspect (call it Classic, Regular, or whatever...) you need NOW to add in your line code (the one you copy to paste it your website) the instruction : "&visual=false".
Without this instruction, the Visual aspect is the one directly used, even if you choose the HTML 5 option.
This was not the case until yesterday...
Someone somewhere has changed something !!!
Hours lost and may be...money...

Hi philvern,

Sorry to hear this caused so much inconvenience. I'm currently trying to find the root cause to this, so I have a few more questions:

a) Did you use the WordPress Embed code that you receive by going to the track page, click Share, choose the Embed tab, and ticking the box that says "WordPress code"?

Or did you go another route to get the embedded player?

b) Please guide me to your WordPress website.

Cheers
Mathis
Userlevel 1
Hi
I spent all night repairing my WordPress sites....
The thing is that, in order to have the HTML 5 aspect (call it Classic, Regular, or whatever...) you need NOW to add in your line code (the one you copy to paste it your website) the instruction : "&visual=false".
Without this instruction, the Visual aspect is the one directly used, even if you choose the HTML 5 option.
This was not the case until yesterday...
Someone somewhere has changed something !!!
Hours lost and may be...money...

a) Yes of course, the "normal" route, not another !
b) It's all fixed by now, each track, one by one, in several sites. Nothing anymore to see...
But have a try yourself : the all process of a) choosing HTML 5, inserting it in a Wordpress site... and it gives you NOW a Visual aspect, not HTML 5...
Unless you add this "&visual=false" instruction...
Hi
I spent all night repairing my WordPress sites....
The thing is that, in order to have the HTML 5 aspect (call it Classic, Regular, or whatever...) you need NOW to add in your line code (the one you copy to paste it your website) the instruction : "&visual=false".
Without this instruction, the Visual aspect is the one directly used, even if you choose the HTML 5 option.
This was not the case until yesterday...
Someone somewhere has changed something !!!
Hours lost and may be...money...

Hey Mathis,

Any progress on the bug? I'm experiencing the same issue. You can see it here: http://comingofagestories.wordpress.com/
Hi
I spent all night repairing my WordPress sites....
The thing is that, in order to have the HTML 5 aspect (call it Classic, Regular, or whatever...) you need NOW to add in your line code (the one you copy to paste it your website) the instruction : "&visual=false".
Without this instruction, the Visual aspect is the one directly used, even if you choose the HTML 5 option.
This was not the case until yesterday...
Someone somewhere has changed something !!!
Hours lost and may be...money...

Hi Coming of Age,
Why don't you do what Philvern did?
It worked fine for me ! Thanks to him...
We don't necessarily have time to let our website in such a pity condition, waiting for a bug repairing coming one day...
Hi
I spent all night repairing my WordPress sites....
The thing is that, in order to have the HTML 5 aspect (call it Classic, Regular, or whatever...) you need NOW to add in your line code (the one you copy to paste it your website) the instruction : "&visual=false".
Without this instruction, the Visual aspect is the one directly used, even if you choose the HTML 5 option.
This was not the case until yesterday...
Someone somewhere has changed something !!!
Hours lost and may be...money...

Can you paste an example of what the code looks like on your site now? I tried the solution philvern recommended this morning, but could not get it to resolve. I'm a bit unsure if I'm adding the "visual=false" code in the right place.
Hi
I spent all night repairing my WordPress sites....
The thing is that, in order to have the HTML 5 aspect (call it Classic, Regular, or whatever...) you need NOW to add in your line code (the one you copy to paste it your website) the instruction : "&visual=false".
Without this instruction, the Visual aspect is the one directly used, even if you choose the HTML 5 option.
This was not the case until yesterday...
Someone somewhere has changed something !!!
Hours lost and may be...money...

Wait, just figured it out. Had to look at the code string for the visual mode to figure out where to place the "visual=false" string. Thanks for the encouragement talismen. Now I can fix it instead of waiting for Soundcloud to sort it out.
Hi
I spent all night repairing my WordPress sites....
The thing is that, in order to have the HTML 5 aspect (call it Classic, Regular, or whatever...) you need NOW to add in your line code (the one you copy to paste it your website) the instruction : "&visual=false".
Without this instruction, the Visual aspect is the one directly used, even if you choose the HTML 5 option.
This was not the case until yesterday...
Someone somewhere has changed something !!!
Hours lost and may be...money...

Yeah! All thumbs up to Philvern who has sort it out...
Userlevel 1
Hi
I spent all night repairing my WordPress sites....
The thing is that, in order to have the HTML 5 aspect (call it Classic, Regular, or whatever...) you need NOW to add in your line code (the one you copy to paste it your website) the instruction : "&visual=false".
Without this instruction, the Visual aspect is the one directly used, even if you choose the HTML 5 option.
This was not the case until yesterday...
Someone somewhere has changed something !!!
Hours lost and may be...money...

Thanks! Glad to have helped...

Mathis, Where have you been ?
Have you founded the "root cause" to this mess ?
Userlevel 1
Hi
I spent all night repairing my WordPress sites....
The thing is that, in order to have the HTML 5 aspect (call it Classic, Regular, or whatever...) you need NOW to add in your line code (the one you copy to paste it your website) the instruction : "&visual=false".
Without this instruction, the Visual aspect is the one directly used, even if you choose the HTML 5 option.
This was not the case until yesterday...
Someone somewhere has changed something !!!
Hours lost and may be...money...

Thanks! Glad to have helped...

Mathis, Where have you been ?
Have you founded the "root cause" to this mess ?
Userlevel 7
Badge +3
Hi
I spent all night repairing my WordPress sites....
The thing is that, in order to have the HTML 5 aspect (call it Classic, Regular, or whatever...) you need NOW to add in your line code (the one you copy to paste it your website) the instruction : "&visual=false".
Without this instruction, the Visual aspect is the one directly used, even if you choose the HTML 5 option.
This was not the case until yesterday...
Someone somewhere has changed something !!!
Hours lost and may be...money...

Hey there,

Sorry about the late reply. Hmm, so I haven't heard back from our engineers about this. However, Wordpress can sometimes be tricky, as it uses our embed code slightly differently then other websites.

I'm glad that philvern was able to help you, talismen, with this.

Maybe also worth taking a look: https://wordpress.org/plugins/soundcloud-shortcode/ Once installed, you can set which default player you want (it hasn't been updated in a hot minute, so it still contains the Flash option, which I don't suggest). In your case, this would be the html5 player. Then you can use the following formular, and the plugin will do the rest for you:



Maybe worth a shot? If I hear back from our engineers, I'll make sure to let you know here.

Cheers
Mathis
Userlevel 1
Hi
I spent all night repairing my WordPress sites....
The thing is that, in order to have the HTML 5 aspect (call it Classic, Regular, or whatever...) you need NOW to add in your line code (the one you copy to paste it your website) the instruction : "&visual=false".
Without this instruction, the Visual aspect is the one directly used, even if you choose the HTML 5 option.
This was not the case until yesterday...
Someone somewhere has changed something !!!
Hours lost and may be...money...

Easy! Mathis it's UNSOLVED, not SOLVED... Until your engineers repair the problem...
Which is :
1/ Add the instruction &visual=false (still not done, why ?)
2/ Clarify how the code effect has changed...
The plugin you mention seem to arise some other types of concerns (see support).
I believe so far my way is the easiest one. But I may be wrong.
Cheers
Stll not fixed - very frustrating and disapointing. I'll try Philverns fix for now but come on guys...
philverns fix works great, but it's a lot of work to fix on my site 😕
Userlevel 1
philverns fix works great, but it's a lot of work to fix on my site :-/
Yes Ryan... It took me all night repairing mines...
A bit of a shame it's not fixed yet from the source...
And that topic marked SOLVED when it is NOT...!
Userlevel 7
Badge +3
Hi there,

Sorry about the confusion with the status on this conversation. I've now changed this to "in progress". Our engineers have been made aware of this and are looking into the issue right now.

I will make sure to provide an update as soon as I have news.

Thanks for your continued patience, much appreciated!

Cheers
Mathis
Userlevel 1
Hi there,

Sorry about the confusion with the status on this conversation. I've now changed this to "in progress". Our engineers have been made aware of this and are looking into the issue right now.

I will make sure to provide an update as soon as I have news.

Thanks for your continued patience, much appreciated!

Cheers
Mathis

Ok Mathis, but please make sure we won't have to fix back again our stuff once your engineers will update the code. Have you transferred MY (very very quick & simple) solution ?
Userlevel 7
Badge +3
Hi there,

Sorry about the confusion with the status on this conversation. I've now changed this to "in progress". Our engineers have been made aware of this and are looking into the issue right now.

I will make sure to provide an update as soon as I have news.

Thanks for your continued patience, much appreciated!

Cheers
Mathis

Hi philvern,

Forwarded, all of it 🙂
Userlevel 7
Badge +3
Hi there,

Sorry about the confusion with the status on this conversation. I've now changed this to "in progress". Our engineers have been made aware of this and are looking into the issue right now.

I will make sure to provide an update as soon as I have news.

Thanks for your continued patience, much appreciated!

Cheers
Mathis

Hi again,

Just a quick heads up - our developers just got back to me and informed me that they've gotten in touch with the devs over at WordPress. The fix will be coming from their end, so we're hoping this will soon be sorted. We'll follow up accordingly.

Have a good weekend.

Cheers
Mathis

Reply