Question

Embed

  • 29 November 2014
  • 15 replies
  • 332 views

Why do some songs have embed, but others don't?

15 replies

Userlevel 7
Badge +3
Hi there Chris,

Thanks for your question - nice one! Whether or not a track can be embedded is up to the original uploader. In the settings of their tracks and playlists, they can choose whether or not to show the embed code. Here's how that looks:



Hope that helps!

Cheers,
Mathis
Hi there Chris,

Thanks for your question - nice one! Whether or not a track can be embedded is up to the original uploader. In the settings of their tracks and playlists, they can choose whether or not to show the embed code. Here's how that looks:

Hope that helps!

Cheers,
Mathis

I have the same problem. I am the original uploader (and the artist). When I try to share a track (to Wordpress) I am offered 2 options: SHARE, and MESSAGE, no EMBED. Underneath the player it says 'Share' and icons for Facebook, Twitter, Tumbler, Google +, Pinterest, and email -- no Wordpress. I cannot find any page in Soundcloud that resembles what you posted.
Userlevel 7
Badge +3
Hi there Chris,

Thanks for your question - nice one! Whether or not a track can be embedded is up to the original uploader. In the settings of their tracks and playlists, they can choose whether or not to show the embed code. Here's how that looks:

Hope that helps!

Cheers,
Mathis

Hey there J,

Sorry about the delay in responding here. Hmm, ok let's see. Would you mind sending over the track title or direct link to the track you're referring to? This way I will be able to take a closer look.

The page shown in the attached image can be accessed as follows: Go to a track of yours and click on the small "Pen" icon. This will bring you to the track's edit mode. Please note that this is currently only available via a web browser on the desktop version of SoundCloud.com, not via the mobile site or mobile app(s).

Cheers,
Mathis
Hi there Chris,

Thanks for your question - nice one! Whether or not a track can be embedded is up to the original uploader. In the settings of their tracks and playlists, they can choose whether or not to show the embed code. Here's how that looks:

Hope that helps!

Cheers,
Mathis

Dear Mathis, Thanks very much for getting back to me. In the end, it was the old culprit, "user error." I just couldn't figure out how to turn on the embed, and I finally figured it out. So I'm OK now. Thanks again for the response, and I apologize for the bother. Chris
Userlevel 7
Badge +3
Hi there Chris,

Thanks for your question - nice one! Whether or not a track can be embedded is up to the original uploader. In the settings of their tracks and playlists, they can choose whether or not to show the embed code. Here's how that looks:

Hope that helps!

Cheers,
Mathis

Hey Chris,

Glad to hear this is now working for you 🙂
Mathis:
Finally figured it out. You have to click on "permissions" then the grayed-out "display embed code", then "save changes". Guess I need things spelled out for me. Thanks for getting back to me.
Userlevel 7
Badge +3
Mathis:
Finally figured it out. You have to click on "permissions" then the grayed-out "display embed code", then "save changes". Guess I need things spelled out for me. Thanks for getting back to me.

Hey J,

Thanks for the update - that is awesome!

Happy Embedding ;-)

Cheers,
Mathis
Mathis:
Finally figured it out. You have to click on "permissions" then the grayed-out "display embed code", then "save changes". Guess I need things spelled out for me. Thanks for getting back to me.

I'm having a problem like this, but the display embed code box is checked. But the share buttons are not available for the track. Is it a problem with my chrome browser maybe? Also in all the help pics you've posted it's showing a pro plan settings page. Are the share features only available to pro users? Just wondering, because I'm not likely to become a paid user myself until I can work these problems out. I'm mostly interested in embedding tracks to my DeviantArt.com journal so I can blog about the track I've created. I've seen other DA users add soundcloud tracks to their journals so I know it can be done, but I haven't had access to my embed codes yet. I'm uploading on soundcloud just for this reason, so it's pretty frustrating.
Userlevel 7
Badge +3
Mathis:
Finally figured it out. You have to click on "permissions" then the grayed-out "display embed code", then "save changes". Guess I need things spelled out for me. Thanks for getting back to me.

Hey 53302,

Can you let me know which track of yours it is that you're attempting to embed? I can then take a closer look and investigate for you.

Looking forward to hearing from you.
Cheers,
Mathis
Userlevel 7
Badge +3
Mathis:
Finally figured it out. You have to click on "permissions" then the grayed-out "display embed code", then "save changes". Guess I need things spelled out for me. Thanks for getting back to me.

Sorry, forgot to comment on Pro / Non-Pro features.

All users can embed tracks from SoundCloud. Free users can embed tracks & playlists using the Visual Player and the HTML5 player. Pro Unlimited users can use an additional design, which is the mini player.

For details on the different embedded players, please also take a look at our Help Center article: http://help.soundcloud.com/customer/portal/articles/1428418-what-are-the-differences-between-the-emb...

Best,
Mathis
This reply was created from a merged topic originally titled Share buttons and embed codes not available on tracks.

Yes the display embed code box is checked. It seemed to be this way by default. But the share buttons are not available for any tracks. Is it a problem with my chrome browser maybe? Also in all the help pics you've posted are showing a pro plan settings page. Are the share features only available to pro users? Just wondering, because I'm not likely to become a paid user myself until I can work these problems out. I'm mostly interested in embedding tracks to my DeviantArt.com journal so I can blog about the track I've created. I've seen other DA users add soundcloud tracks to their journals so I know it can be done, but I haven't had access to my embed codes yet. I'm uploading on soundcloud just for this reason, so it's pretty frustrating, because the only share button available is the one on my profile page, and that only worked once in my facebook newsfeed, and now only links back to soundcloud every time I try to use it again. Even when posting it on my Google+ account.
Mathis:
Finally figured it out. You have to click on "permissions" then the grayed-out "display embed code", then "save changes". Guess I need things spelled out for me. Thanks for getting back to me.

All the tracks on my account are having the same problem but you can look at this one as an example.
https://soundcloud.com/latetalk-1/dante-sangreal-and-the-voynich-manuscript
Mathis:
Finally figured it out. You have to click on "permissions" then the grayed-out "display embed code", then "save changes". Guess I need things spelled out for me. Thanks for getting back to me.

I figured out share buttons are not available under "tracks" or "profile" but when I did a soundcloud site search with terms specific to my uploads the share buttons are on my tracks that appear from the search. I guess I'm just a soundcloud newbie, but it seems kinda confusing.
Mathis:
Finally figured it out. You have to click on "permissions" then the grayed-out "display embed code", then "save changes". Guess I need things spelled out for me. Thanks for getting back to me.

In case others are trying to embed to DeviantArt here's the instructions that worked for me.

GET THE ID CODE BY:

1. Go to song of choice

2. Click the "Share" button

3. Click "Embed"

4. Retrieve song ID in the coding.
The ID in this case is bold and underlined.

<iframe width="100%" height="450" scrolling="no" frameborder="no" src="w.soundcloud.com/player/?url=h...164305330&amp;auto_play=false&amp;hide_related=false&amp;show_comments=true&amp;show_user=true&amp;show_reposts=false&amp;visual=true"></iframe>

5. Copy + paste the set of numbers into embed code:

<!!!da:embed profile="soundcloud" id="[INSERT SONG ID HERE]" width="100%" height="200"!!!>

keep INSIDE the brackets and remove "!!!"
Userlevel 7
Badge +3
Mathis:
Finally figured it out. You have to click on "permissions" then the grayed-out "display embed code", then "save changes". Guess I need things spelled out for me. Thanks for getting back to me.

Hi again,

Thanks for following up on this! Glad you were able to figure this out - I wasn't aware DeviantArt needed a special type of treatment when it comes to SoundCloud embeds ;-)

Happy embedding then! 🙂

Reply