Answered

embed code change


When I built our site I used the iframe embed code with the use of the long url and it worked fine. (I believe that is how it was displayed back then as well)
"https://w.soundcloud.com/player/?url=https://soundcloud.com/bettheboard/nfl-week-5-betting-picks-mnf-minnesota-vikings-vs-chicago-bears-tom-waddle-of-espn-joins"

Now the iframe will only work if the URL looks like:
https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/346102125

We are also noticing it does not work on itunes as well

Is SoundCloud going re-enable both ways? Or is there a fix for old posts?
icon

Best answer by Mathis 10 October 2017, 17:12

Update: Just had the SoundCloud blog to test, but you should all be all set again, too. 🙂 Thanks for reporting and for your patience.

For future reference (fingers crossed you won't have to report again): see if you can provide the URL to your website / blog / forum etc. so others on the community can troubleshoot right away.
View original

18 replies

came here to find an answer on the same issue.

this looks like a bug because there is an exception :
Exception: Uncaught TypeError: Cannot read property 'replace' of undefined - widget-93da14a-76f44a7b.js:14

this is also broken at the soundcloud api playground -> https://w.soundcloud.com/player/api_playground.html
Glad I am not alone. If you find the answer, please let me know.
Same error here and error message. Nothing from soundcloud dev team yet?
Userlevel 1
Don't know if it's related but the online forums that have SoundCloud embed links seem to all be broken right now, too.
Not all forums are broken (KVR works fine, for example), but ironically, the embedded link on SoundCloud's own blog explaining how to embed links on forums are broken: https://blog.soundcloud.com/2009/07/28/soundcloud-player-in-forums-5-step-guide-for-soundcloud-bb-code/

Was broken on the Image-Line forums, but they have since fixed things on their end, so it's working again. The SoundCloud blog link is still borked though.
I'm also having this problem. The Embed links generated on the soundcloud pages have changed formats; rather than having the url to the recording as part of the src url in the iframe code, they have some link to the API that cannot be deduced directly from the url to the recording.
We are also having this issue and the same error.
This is having a huge impact on our site right now. Are you guys fixing this or is allowing long urls in the iframe player being deprecated? If it's the latter, then it seems to only other solution to embedding SC long urls is to use oEmbed, which coincidentally is impossible for users that don't already have a client_id (since you're not allowing new registrations).

Can someone from soundcloud provide a response?
@Mathis do you know what's going on here?
Userlevel 7
Badge +3
Hi there everyone,

Apologies about this. I've just reached out to the respective engineering team about this and it looks like this is a bug. The issue should be resolved soon. We'll keep you posted.

Thanks for hanging in there.
Thanks @Mathis for the quick response. Please keep the pressure on them!! Also I'm sure all the people here would appreciate it if you could update this thread when it's fixed.
Hi All, Please push this topic up, by tweeting it to soundcloud: @scsupport
Userlevel 7
Badge +3
Thanks @Mathis for the quick response. Please keep the pressure on them!! Also I'm sure all the people here would appreciate it if you could update this thread when it's fixed.

Jup, will do.
Userlevel 7
Badge +3
Update: Just had the SoundCloud blog to test, but you should all be all set again, too. 🙂 Thanks for reporting and for your patience.

For future reference (fingers crossed you won't have to report again): see if you can provide the URL to your website / blog / forum etc. so others on the community can troubleshoot right away.
Thank you SoundCloud, it is now working for me.
Yes, it is working for us too. Thank you!
It's working. Thanks for the speedy response!!!
yes, it is working, thanks

Reply