Answered

Embed shows 100x100px artwork. How to get the 500x500?

  • 23 February 2017
  • 3 replies
  • 219 views

I tried to embed to embed two tracks on a page, but the embedded player uses the -large (100x100) artwork instead of the t500x500 artwork. The size of the -original version of the artwork is 600x600, so it is unclear to me why that particular version is used. Since the iframe it contains is 300x300 pixels, the artwork is pixelated.

What causes the 100x100 version to be used? Can I force it to use the 500x500 or original version instead? Is there something the uploader can do to make the embedded player use the 500x500 automatically?

icon

Best answer by Sumurai8 24 February 2017, 18:53

I have seen embedded tracks with t500x500 images, so it does not seem to be completely broken. In any case, I decided to just hide the iframe, and use the SC.Widget methods to interact with it to create my own view. (https://developers.soundcloud.com/docs/api/html5-widget)
View original

3 replies

It looks like a problem happening on the site, not just with embedding.
See here: https://soundcloudcommunity.com/account-access-copyright-trust-safety-229932/blurry-profile-pictures-7354768
I have seen embedded tracks with t500x500 images, so it does not seem to be completely broken. In any case, I decided to just hide the iframe, and use the SC.Widget methods to interact with it to create my own view. (https://developers.soundcloud.com/docs/api/html5-widget)
Userlevel 7
Badge +3
Hi there,

@Samurai8 - thanks for sharing your solution!

Hmm, maybe it's the difference between the regular HTML5 embedded player and the visual embedded player? Here's an overview. (the parameter in question would be show_visual=true

Reply