Question

Embed Using WordPress Post Format Function

  • 29 December 2015
  • 3 replies
  • 226 views

My text below references this screenshot: http://www.yourleadershipgap.com/wp-content/uploads/2015/12/Screen-Shot-2015-12-29-at-2.06.09-PM.png

Notice the "Format" box on the right hand. I have check marked "Audio". Then on the left, under the post, I have posted in my Link Audio. When I do this, however, it does not show up on my published post.

I am aware of how to embed the post right into the body using the code from SoundCloud, but I would prefer not to do this. It won't show up in the spot I want, and causes a few other problems.

Is there a "Link Audio" URL I am not using but should be? I've tried all sorts of combinations. Any ideas?

FYI, below that you can see an option for video and Vimeo. I have tried this and it works fine, so the problem seems to be unique to audio / SoundCloud.

Thanks!
~Colby

3 replies

Userlevel 7
Badge +3
Hi there Colby,

Hmm, let's see. In order for this to work with SoundCloud links, WordPress would need to implement this via our public API on their end. We do have a shortcode plugin for WordPress here, which, once installed, makes embedding a bit easier. (please note that the plugin has not been updated in a while. It should still work for the Visual and HTML5 player though).

Hope this helps to shed some light on the case.

Cheers
Mathis
That Wordpress plugin has not been updated in 2 years, meaning there is a high degree of probable operating and security conflicts.

You can put the <iframe> code in a <div> tag such as:

<div align="center">
put the <iframe> code from soundcloud here
</div>

Soundcloud needs to address this common issue. We did the Wordpress insertion and it simply showed up as text, so we switched to the <iframe> snippet.
Hi there Colby,

Hmm, let's see. In order for this to work with SoundCloud links, WordPress would need to implement this via our public API on their end. We do have a shortcode plugin for WordPress here, which, once installed, makes embedding a bit easier. (please note that the plugin has not been updated in a while. It should still work for the Visual and HTML5 player though).

Hope this helps to shed some light on the case.

Cheers
Mathis

We did some research on this issue and it looks like the Soundcloud problems with the Wordpress embed has been going on for a long time without substantive resolution. We just opened our account and find this more than disturbing. With WP running about 23% of the websites worldwide, it should be addressed. Soundcloud doesn't seem to have a support ticket system for pro accounts. Soundcloud should address the WP issue asap. Thanks for your communication.

Actually, the Wordpress check box in Soundcloud is ONLY for Wordpress.com hosted sites, and won't work without a plugin in free standing WP sites.

Use Jetpack and in Settings activate the "Shortcode Embeds" function.

Finally, we are told you can embed the following code in the functions.php file and this will make it work... did NOT try this...just make sure its inside <?php ?>

// Add SoundCloud oEmbedfunction add_oembed_soundcloud(){ wp_oembed_add_provider( 'http://soundcloud.com/*', 'http://soundcloud.com/oembed' ); } add_action('init','add_oembed_soundcloud');

Reply