Flash Blocked on Google Chrome Preventing SoundCloud API from Loading

  • 2 March 2017
  • 4 replies

Hey all,

I built a website for my music ( in October and upon revisiting it this week I found that it no longer works in Google Chrome. I get this error

when the song should load. It still works in Firefox, and it appears that the issue is that Chrome is blocking Flash, which prevents the rest of the API from loading. Has anybody else had this issue? Found workarounds? I tried allowing the plugin in Chrome, but for whatever reason that doesn't stop the error. Any help would be greatly appreciated.


4 replies

Hi! I'm having same issue. I see you have sound on your site now. How did you get it working?
Hey Alex,

I'm still having the issue when I go visit the site. Can you screenshot what it looks like when you have it working? What browser are you using? Maybe we can start to figure this out together.

Hi Simulcast,
When I scroll down to the names of the tracks It starts playing automatically. I use Chrome Version 57.0.2987.133 (64-bit)
on OS X. The console gives a few of js errors, but nothing related to Soundcloud or Flash (see the attachment). I personally dug into some forums and found a solution to my issue. It was in player.options.protocols array. If the first value in this array is "rtmp", the player tries to use flash and fails. In my case, this array contained only 2 values "rtmp" and "http", so I reversed it, and it works perfectly now. However on your site initial_track.options.protocols in my case returns an array with only one value "http", so it works ok.
I found this solution here:
Hey Alex,

Thanks for your help! I did the same thing (reversed the rtmp / http protocols in the player.options.protocols array) and it works beautifully now. Seems like it was defaulting to flash and my browser was blocking it. Perhaps in browsers without flash installed this doesn't happen.

Many thanks again,