Question

Mini embed audio file is set to autoplay=false. When I embed in my wordpress page the code changes to autoplay=true in web page code


My mini embed audio file is set to autoplay=false. But when I embed it in my wordpress page the code changes to autoplay=true in the web page source code

Here is the code from the embed tool that I am putting on my text/html wordpress page

[soundcloud url="https://api.soundcloud.com/tracks/214894207?secret_token=s-afaeh"; params="color=ff5500&inverse=false&auto_play=false&show_user=true" width="100%" height="20" iframe="true" /]

Here is the source code on the Firefox (39.0) browser page. I also tested in (IE 11.0.9600.171105) with the same result but it doesn't autoloay on an iPhone.

<iframe width="100%" height="20" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?url=https%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F214894207%3Fsecret_token%3Ds-afaeh&amp;show_comments=true&amp;auto_play=true&amp;color=ff7700"></iframe>
&nbsp;</p>
Here is the page and site I am developing

http://184.154.233.249/~c11thste/index.php/meditate-on-each-step/177-2/

How can I get the autoplay setting to false on the live pages? Why is it doing this?

Thanks,

Randy

4 replies

Userlevel 7
Badge +3
Hi Randy,

Hmm, quite strange actually. Well, let's see. First things first - there is not an option to enable / disable autoplay for iOS - autoplay on iOS is disabled either way (i.e., the parameter doesn't affect mobile browsers).

Other then that, I've tried to embed your code on my test WordPress account, and it was working just fine actually. Thus, it seems like this manipulation happens when saving your code on WordPress. Have you reached out to them to see if there's something they can do to help? Also, from experience, it sometimes is the custom theme that can cause unexpected behavior. Any chance you can try the same embed on a blank test page?

Let us know how it goes, and if you have further questions.

Cheers
Mathis
Thanks, Mathis. I posted on the Wordpress forum and the Evolve Theme developer support site and got no response.

I just tried using the standard mini player iFrame code and did not check the Wordpress shortcut code option. It works with just the iFrame code and does not auto-play!

Hopefully this will help someone else in the future and save them the 2+ hours I spent on it.

Randy
Userlevel 7
Badge +3
11th wrote:

Thanks, Mathis. I posted on the Wordpress forum and the Evolve Theme developer support site and got no response.

I just tried using the standard mini player iFrame code and did not check the Wordpress shortcut code option. It works with just the iFrame code and does not auto-play!

Hopefully this will help someone else in the future and save them the 2+ hours I spent on it.

Randy


Hey there,

Good stuff - thanks so much for following up on this, much appreciated!
Mathis wrote:

Hi Randy,

Hmm, quite strange actually. Well, let's see. First things first - there is not an option to enable / disable autoplay for iOS - autoplay on iOS is disabled either way (i.e., the parameter doesn't affect mobile browsers).

Other then that, I've tried to embed your code on my test WordPress account, and it was working just fine actually. Thus, it seems like this manipulation happens when saving your code on WordPress. Have you reached out to them to see if there's something they can do to help? Also, from experience, it sometimes is the custom theme that can cause unexpected behavior. Any chance you can try the same embed on a blank test page?

Let us know how it goes, and if you have further questions.

Cheers
Mathis

Reply