Question

Problem with soundcloud player on facebook page

  • 18 December 2014
  • 57 replies
  • 1801 views

Hey, i'm having a problem when i post a soundcloud link to my music page. The actual player isn't coming up on my page, only the link with a picture so people have to click it and go to soundcloud to hear the sound. It works fine on my facebook profile, or on a facebook event page but not on my artist page.

I tried the de-bugging thing and after fetching new scrape information it tell me: "Errors That Must Be FixedCircular Redirect PathCircular redirect path detected (see 'Redirect Path' section for details)."

my page is https://www.facebook.com/solmanmusic
and one of the tracks i want to post is https://soundcloud.com/solmanmusic/eden-again
any help is much appreciated :)

bless

57 replies

I'm having exactly the same problem, since yesterday!
Same problem here, I also have the same problem embedding the tracks into Facebook messages

Please help sound cloud. This is really affecting my promo 😞
Userlevel 7
Badge +3
Hi guys,

Thank you for your post. I am terribly sorry, but at this time, I have to admit there is not a workaround for this - the fact that SoundCloud links currently don't render into the embedded player on Facebook artist / bandpages is due to a change that Facebook made on their end. We have reached out to them and our developers are currently looking into ways to sort this out, however this is one is not entirely on us to decide.

I'm hoping I can soon update this conversation with better news.

Thanks for your patience guys, much appreciated!

Cheers,
Mathis
Yeah the jukebox type player from the profile page share button posted only once. Now it won't post again anywhere, and only links back to my soundcloud account. None of the share buttons are available for individual tracks like demonstrated in your help pages. I'm mostly interested in embedding tracks to my journals on DeviantArt, and sharing the jukebox on a facebook fan page I'm creating.
That jukebox won't work on Google+ ether. 😞
Strangely it seems to be a problem with the timeline... when I view the post by itself, it works.
Same here, if I post it on my personal page the play icon is displayed and works like a charm. But if you do it on a FB FanPage you get the static artwork with no play icon and opens another page redirecting to SoundCloud. I started linking from Bandcamp which works perfect. But I hope this is solved since Soundcloud player and widget was far cooler than Bandcamp.
https://www.soundcloudcommunity.com/soundcloud/topics/soundcloud-link-pasted-on-facebook-need-help-p...

Shadanga I tried through ie, firefox and chrome, and in the timeline you can see the embeded widget with the play icon perfectly, but ON the page no, just the static artwork

Thanks Mathis and djraveninpeace for the comments
Userlevel 7
Badge +3
Same here, if I post it on my personal page the play icon is displayed and works like a charm. But if you do it on a FB FanPage you get the static artwork with no play icon and opens another page redirecting to SoundCloud. I started linking from Bandcamp which works perfect. But I hope this is solved since Soundcloud player and widget was far cooler than Bandcamp.
https://www.soundcloudcommunity.com/soundcloud/topics/soundcloud-link-pasted-on-facebook-need-help-p...

Shadanga I tried through ie, firefox and chrome, and in the timeline you can see the embeded widget with the play icon perfectly, but ON the page no, just the static artwork

Thanks Mathis and djraveninpeace for the comments

Hi Hernan,

If I remember correctly, I've responded to you in a different conversation on this particular topic before. Nevertheless, let's make sure you're in the loop 🙂 Posting on Facebook artist / band pages currently does not render our embedded player. This is unfortunately, and our developers are looking in to ways to fix this. It was original caused by a change that Facebook made, so we need to work something out in correspondence with them. We're hoping that this can soon be sorted.

In the meantime, you might be able to get the player to render in comments that you post under the original post on your artist page (thanks to djraveinpeace, who has posted this on the help forum before).

Happy holidays to you Hernan, all the best!

Cheers,
Mathis
Same here, if I post it on my personal page the play icon is displayed and works like a charm. But if you do it on a FB FanPage you get the static artwork with no play icon and opens another page redirecting to SoundCloud. I started linking from Bandcamp which works perfect. But I hope this is solved since Soundcloud player and widget was far cooler than Bandcamp.
https://www.soundcloudcommunity.com/soundcloud/topics/soundcloud-link-pasted-on-facebook-need-help-p...

Shadanga I tried through ie, firefox and chrome, and in the timeline you can see the embeded widget with the play icon perfectly, but ON the page no, just the static artwork

Thanks Mathis and djraveninpeace for the comments

Hi Mathis,
I hope the developers are going prioritize this. In my case FB users are far more reluctant to listen to music when the only option is to click on a static photo that takes them to another site. I stopped posting my songs because of this. Any sense of when this will be resolved? Thanks and happy New Year!
Same here, if I post it on my personal page the play icon is displayed and works like a charm. But if you do it on a FB FanPage you get the static artwork with no play icon and opens another page redirecting to SoundCloud. I started linking from Bandcamp which works perfect. But I hope this is solved since Soundcloud player and widget was far cooler than Bandcamp.
https://www.soundcloudcommunity.com/soundcloud/topics/soundcloud-link-pasted-on-facebook-need-help-p...

Shadanga I tried through ie, firefox and chrome, and in the timeline you can see the embeded widget with the play icon perfectly, but ON the page no, just the static artwork

Thanks Mathis and djraveninpeace for the comments

Yes Matt, I also started linking from Bandcamp, since the embedded player works fine on FB. Anyway, I hope I can go back to linking from Soundcloud ASAP, since the player and everything is far cooler in my view on Soundcloud. Regards.
Same here, if I post it on my personal page the play icon is displayed and works like a charm. But if you do it on a FB FanPage you get the static artwork with no play icon and opens another page redirecting to SoundCloud. I started linking from Bandcamp which works perfect. But I hope this is solved since Soundcloud player and widget was far cooler than Bandcamp.
https://www.soundcloudcommunity.com/soundcloud/topics/soundcloud-link-pasted-on-facebook-need-help-p...

Shadanga I tried through ie, firefox and chrome, and in the timeline you can see the embeded widget with the play icon perfectly, but ON the page no, just the static artwork

Thanks Mathis and djraveninpeace for the comments

Thanks Herman. Yes, I was happily sharing my free downloads from Soundcloud on FB because of the player. Now I'm in a holding pattern...waiting to see if this will soon be fixed or if another resource is required.
I'm having same problem (player won't post on FB, just a page link) as of Jan 24, 2015. But only when posting a song I just uploaded today. Songs I successfully posted a couple of months ago (player shows up) will STILL post a player! This doesn't seem like it's solely a Facebook change (?)
This workaround -- add ?123" to the end of the URL -- just worked for me. See this page.
https://www.soundcloudcommunity.com/soundcloud/topics/solving-facebook-sharing-issues
Hi Mark, thanks but the ?123" didnt work, The play button is not there on my page, it's on the timeline, but not on the page. Sadly I'm posting from bandcamp now. I hope this is worked out so I can start linking from SoundCloud since it was much cooler to me. Thanks and good luck
Having the same problem. Copying the link to Facebook shows a player button in preview, but when posted there is no player. Users must click through to Soundcloud to play a track. Adding ?123 doesn't work for me. Debugging gives this result, but I have no idea how to fix this in Soundcloud. Is there a way to edit the metadata to add this "og:type" property?


The redirects all show the same URL, with no suggestion of how to fix that.
This problem exists for all Facebook types: personal, group and page.
So frustrating. I even tried copying the Facebook share URL and ran that through the debugger. Posting the track again in comments is the only way to get a player to work in the Facebook stream. Pretty clunky. Any other ideas?
I've had some luck lately with posts working (iow, playing) in FB. But it's random! Some don't. Doesn't seem to matter if it's a post, posted in a comment, posted on personal or fan page... I'm not a coder at all so I'm no help. Had almost decided to upgrade to higher SC level and then this starts happening. If this were happening to all SC users (but is it?) surely they'd have fixed it by now.
I'm giving up, and unsubscribing from this thread. Good luck everyone!!
Userlevel 7
Badge +2
I'm giving up, and unsubscribing from this thread. Good luck everyone!!
Hi 53302,

Apologies for the frustration. Please know we are looking into this but it's tricky since some work and some don't. Feel free to take a look back as we will update this thread when we have new information.

Best,
Gina
I'm giving up, and unsubscribing from this thread. Good luck everyone!!
Thanks Gina...
I'm giving up, and unsubscribing from this thread. Good luck everyone!!
Why do some work and some don't? Is that honestly your response to this? Who knows?
I am having the same problem, this was never solved..
I've since noticed YouTube is having the same problem on Facebook! iow no player, just link to the YouTube page. Sorry Soundcloud, maybe Facebook is being an ar$e to everyone.
I've since noticed YouTube is having the same problem on Facebook! iow no player, just link to the YouTube page. Sorry Soundcloud, maybe Facebook is being an ar$e to everyone.
Facebook is known to change their interface a) without warning b) without backwards compatibility. Sadly people always blame the 3rd parties for breaking things. I am afraid that FB has grown too much self-esteem during the last years.
I've since noticed YouTube is having the same problem on Facebook! iow no player, just link to the YouTube page. Sorry Soundcloud, maybe Facebook is being an ar$e to everyone.
Yep, I'm understanding that now.
Userlevel 7
Badge +3
Hi there,

Just dug out this conversation - We had gotten in touch with Facebook and will hopefully be able to continue working closely with their developers to improve the Facebook sharing capabilities further (e.g., improve caching of outdated info when sharing).

For the moment being, we were able to sort out sharing of your tracks to Facebook artist / band pages - Now, when you copy and paste a track URL to your artist of bandpage, it should render into the player properly again and not forward users to SoundCloud for listening any longer.

Happy Sharing,
Mathis

Reply