Answered

Soundcloud tracks won't play on Wordpress, whether embedded or URL

  • 12 December 2016
  • 12 replies
  • 753 views

I have a Wordpress website that I hadn't checked for a while - I checked it this week, and every single soundcloud embed on my site had become a dead grey box with a soundcloud logo in it.

I tried adding a new plug in, no dice. I read the Soundcloud help forum posts. Nothing was relevant. When I go to share- embed on my soundcloud tracks, the preview box is always just the same dead grey box that shows up on my website.

I tried just using the url address, as was suggested. It creates the same grey box.

My tracks still play as normal on the Soundlcoud website itself.

What is going on? Did Soundcloud withdraw support from Wordpress users? If so, is anyone aware of a different website I can use that does what soundcloud used to do so well?

Thank you to anyone who can help me.
icon

Best answer by Heart Beat 20 December 2016, 09:47

I got the answer from support thanks Chris for your help it was the privacy setting on the tracks not just the playlists that blocked the player list

Thanks for reaching out.

Although the playlist on your account is public (https://soundcloud.com/fathersheart/sets/foundations), all of the tracks within that playlist are marked as private so this is why the playlist is empty and people cannot view this content other than you when logged into your own account.

To change your track's privacy setting, simply go to the track you wish to change and click on the small pencil icon (http://bit.ly/YdPAxJ). This will bring you into edit mode. From here you can change the track to be either private or public below the Description section like this: http://cl.ly/image/3m1y3c3F3p3s

You can do this for multiple tracks at once by following this guide from our help center: http://uploadandmanage.help.soundcloud.com/customer/portal/articles/2163859-changing-your-track-s-privacy-setting

Hope this helps!

Best,
Kellen
View original

12 replies

I have the same issue. This is the very reason I use soundcloud? I see there is no answer for 7 days now on this?
I suggest you complain via twitter as they not doing anything on the forum here @SCsupport
code:
[soundcloud url="https://api.soundcloud.com/playlists/284357579" params="auto_play=false&hide_related=false&show_comments=true&show_user=true&show_reposts=false&visual=true" width="100%" height="300" iframe="true" /]


It's working on my wordpress site. Might want to check your code as Soundcloud gives you an option to insert code as iframe or wordpress code.
code:

Experiment with both to see if it works for you.
I use the iframe - It has always worked now why wouldn't it suddenly work?
Do i need to load a plugin for the WP code to work?
It seems i need a plugin what exact plugin do I need?
I didn't need a plugin for soundcloud embed to work on wordpress.

https://en.support.wordpress.com/soundcloud-audio-player/

mine wont work at all even when i use the correct code
Link your wordpress so I can scan your source code for possible errors.
I got the answer from support thanks Chris for your help it was the privacy setting on the tracks not just the playlists that blocked the player list

Thanks for reaching out.

Although the playlist on your account is public (https://soundcloud.com/fathersheart/sets/foundations), all of the tracks within that playlist are marked as private so this is why the playlist is empty and people cannot view this content other than you when logged into your own account.

To change your track's privacy setting, simply go to the track you wish to change and click on the small pencil icon (http://bit.ly/YdPAxJ). This will bring you into edit mode. From here you can change the track to be either private or public below the Description section like this: http://cl.ly/image/3m1y3c3F3p3s

You can do this for multiple tracks at once by following this guide from our help center: http://uploadandmanage.help.soundcloud.com/customer/portal/articles/2163859-changing-your-track-s-privacy-setting

Hope this helps!

Best,
Kellen

Reply