Question

Twitter share function doesn't transfer track information or link

  • 18 March 2015
  • 5 replies
  • 130 views

Hi there. I make a podcast for a school, and we embed every episode on our website. It was recently brought to my attention that when someone tries to use the share-to-Twitter function on our embedded players, this is what pops up:


No description. No link to the episode. Just the first two words of the episode title.

Whereas sharing to Facebook, Tumblr, email, etc. all seem to work fine, bringing up a post/message with all of the info and the link.

What's happening here? I don't seem to be able to alter this in the HTML that I use to embed. Can anyone help?

Thanks much!
Jake

5 replies

Userlevel 7
Badge +3
Hey there,

Thanks for reporting this. Hmm, let's see - I've just shared your most recent track to Twitter via the Share button and was able to get it through to Twitter just fine: http://cl.ly/image/0w3N3K2i3q18

Can you try to share it again and see if it works properly now? This issue can sometimes occur when Twitter has stored outdated information about your tracks in their cache. Unfortunately, when this happens, we have little control over this, however Twitter's caches clear over time so that sharing the track again at a later stage then works well.

Hope this helps to shed some light on this.
Cheers
Mathis
Hi Mathis,

Thanks for your reply! The share function on our SoundCloud page is fine, yeah. I'm actually referring to the share function in our embedded players, like the one here: http://harris.uchicago.edu/news-and-events/podcasts/20-billion-equalizer

The share function there still appears to be having the same issue. Any additional insights?

Thanks Mathis!
Jake
Hi Mathis,

Did you finally figure out a solution for this?

I am also facing the same issue. When someone tired to share from the embedded player it just shows the name of the show.

Thanks,
TI
hi same problem here
http://covermagazine.co/september-playlist-7/

it used to work but now no links seen on post how yu solved this??
hi same problem here
http://covermagazine.co/september-playlist-7/

it used to work but now no links seen on post how yu solved this??

Reply