For the love of the high heavens... PLEASE let the Autoplay disabling be permanent.

  • 12 October 2018
  • 3 replies
  • 107 views

I know for a fact that several other people have talked on this but PLEASE, for the love of whoever you believe in, actually give us the option to permanently disable Autoplay. I say this for both the Desktop and the mobile versions.

With the Desktop version, regardless of whether you're logged on or not, you play a different song and the Autoplay automatically turns back on. In some cases, even if you were still in the same song and you didn't do anything, it still turns back on without you knowing.

This is actually even worse in mobile, as disabling the Autoplay Station function does LITERALLY NOTHING. As soon as a song ends, it just jumps into a random song as if the Autoplay Station switch were left on even though it was clearly turned off, and then the switch just turns itself back on.

I get that the platform needs to support creators as well but this has to stop. This is especially the case due to the fact that not only the next song that autoplays is always completely irrelevant to the song before but also the fact that there are tons of people that don't want to have to keep hearing songs right after the other, and just trying to stop the next song is not only a pain on desktop, but it's even more of a pain in the neck especially on mobile. People should be listening to newer artists, but shoving the artists' content down the said people's throats is not the way to go about it. I say this as an artist myself.

3 replies

Userlevel 1
Badge
Hi! Sadly, disabling autoplay is not a feature on SoundCloud. However, this link may provide you with a third-party solution. Hope this helps!
Userlevel 1
Badge
Also, just to add on to my answer just in case this is another solution, but you can disable 'Autoplay station' by clicking on the button circled and then clicking on the slider. If this doesn't help, then I would try out my other answer. Hopefully this also helps! :)

Userlevel 1
OFF ! I freakin set it OFF! But it keeps on freaking switching on again!

Reply