Answered

Album Uploaded, but Save Button Won't Work?

  • 15 December 2017
  • 3 replies
  • 2124 views

I've been trying to upload an 11 track album of some of my fun little mashups to the platform, and have had to upload and reupload these tracks as well as the cover art, description, and all of the tags several times, and to no avail. I've set the release date to today, (December 15th, 2017) and even to the day before, and neither of these things have worked. Everything is finished uploading, and the album says "Ready. Click Save to post this playlist." however no matter how many times I click the save button, it simply doesn't do anything. Furthermore, while I have it in my upload tab currently, if I were to open "Upload" from a different tab on my browser, it no longer appears there, as if it never existed.
I have the latest version of Chrome, and I have plenty of upload minutes in order for this album to be uploaded with no issue. The only thing I could possibly think of is that there are too many specific tags on the album, but at the same time, they're all there to reference the songs and artists I've used in these mashups, and to categorize this as a Meme album. I have also tried signing out and signing back in and then uploading again, but still to no avail.
Attached are three images that show the album in its current state on the tab in my browser. I will continue to keep this tab open in case there is some fixing I can do on this page, otherwise if anyone else can help me in any way, please do so.
Thank you in advance.
icon

Best answer by Fire 15 December 2017, 15:30

It probably is the tags. Try closing the browser and leave it for a couple minutes then try again. (hoped i helped!) 🙂
View original

This topic has been closed for comments

3 replies

Userlevel 2
It probably is the tags. Try closing the browser and leave it for a couple minutes then try again. (hoped i helped!) 🙂
Yup! Got it up now.
Userlevel 2
Glad i helped! ^^