Answered

Getting HTTP 404 errors on API calls.

  • 31 January 2017
  • 6 replies
  • 1069 views

I was using soundcloud to repost tracks by this api endpoint:

api.soundcloud.com/e1/me/track_reposts

But it stopped to work. Does someone have more information about it? Is there anyway to repost a track by API?

(stackoverflow is like a desert at this time)
icon

Best answer by National Gallery of Art 27 February 2017, 09:05

For those who experience the same issue,
we solved this by using explicit user ID instead of user permalink.
I.e. Instead of https://api.soundcloud.com/users/{permalink}/tracks" you should use https://api.soundcloud.com/users/{UserId}/tracks

This is according to API endpoint documentation https://developers.soundcloud.com/docs/api/reference#users

Permalink resolution is either broken or no longer supported.
View original

6 replies

Cool. Soundcloud has no support on every channel. Too bad.
Starting past week we're getting HTTP 404 response codes for our API request calls.
For example, for call https://api.soundcloud.com/users/nationalgalleryofart/tracks.json?client_id=337309d4a56a72a41a2b91a2e26c8ccf&oauth_token=&limit=200&offset=0 we're getting response {"errors":[{"error_message":"404 - Not Found"}]}

The same requests were successful prior to last week. Initially we got 404 response code only sometimes (i.e. for each 10th request). But now we're getting 404 for each request.

What would you recommend?
Same here... did they remove this way of accessing the API?
We're having the same issue. Seems like they disabled it? idk
I just ran into this issue. I was able to fix it by using the explicit rather than . Looks like the username resolving is broken.
For those who experience the same issue,
we solved this by using explicit user ID instead of user permalink.
I.e. Instead of https://api.soundcloud.com/users/{permalink}/tracks" you should use https://api.soundcloud.com/users/{UserId}/tracks

This is according to API endpoint documentation https://developers.soundcloud.com/docs/api/reference#users

Permalink resolution is either broken or no longer supported.

Reply