Question

RSS feed not working properly

  • 4 June 2019
  • 1 reply
  • 52 views

Hi community!
I've tried trawling previous Q's & A's, but not come with anything helpful - if there's already an answer or solution, feel free to paste in the link!

I've some issues with the RSS feed associated with my Pro account, where it doesn't seem to update or refresh as it should.
In Apple/iTunes podcasts, it updates as it should from the Soundcloud rss link, but we've got some users on other platforms complaining that our latest episodes doesn't show up.
For instance, if I check overcast I can see our first 13 episodes but then its blank. If I click the RSS feed button, my browser goes blank and doesn't load any information. If I paste the same link from my itunesconnect or Soundcloud settings page, I get redirected straight to my RSS Follower where I can subscribe as per usual.
I've tried setting tracks as private and then back to public, and also refreshing my feed in iTunesconnect, but the issue remains...

Anyone experienced anything like this, and if so, how did you resolve it?

Any assistance well appreciated. Cheers!

1 reply

Userlevel 7
Badge +3
Hi there,

Hmm, have you changed anything since you posted here on the community? From what you're explaining, it sounds like you've accidentally setup a redirect, which happens when you add a URL in the "Subscribers redirect" field. This is only to be used if you want to move to a different host but want to let users still access the old episodes hosted on SoundCloud.

However, when looking at your settings, this does not seem to be the case.

Let us know if this issue persists.

Reply