Question

Track won't upload. Stuck in Save Mode.

  • 6 June 2018
  • 6 replies
  • 2288 views

My track "uploads" the full 51MB's but once it does that, I click save and nothing happens after that. The track won't post or upload.

6 replies

Is anyone else having this problem? Any Suggestions??
Userlevel 7
Badge +3
Hi Nova,

From what I can see, you managed to get your new track uploaded properly now - that's great! Did you do anything in particular to make it work?
Is anyone else having this problem? Any Suggestions??
Yep! Can't "save" the uploaded track. Tried it with 2 different browsers multiple times.
I'm having the same issue in three different browsers. Newest versions.

Since last night, I've tried about 10 times. I can't get my songs to actually save to the platform after the upload progress bars confirm that they're ready. I've entered in all information but when SoundCloud says its ready and I hit 'Save', nothing happens. This is in Chrome, Firefox, and Safari.

Only four tracks and all of them are MP3s. First uploads so I've not hit limits. In this case, I need them to be in a playlist and have chosen "album" because they're from an upcoming album. I've entered title, description, tags, genre, release date. Also uploaded an image. The playlist is set for public viewing.

In metadata, I've entered an iTunes pre-order link and my label name. I've also set permissions.

On one of the attempts, something published to the page but it was only one song out of the four and it had the appearance as though I had uploaded it individually. I deleted it to start fresh but haven't been able to get anything to upload to my page since.

I saw that I can't upload from either of the mobile apps, so I'm also stuck right now. Can't upload anything.
I tried a few different ways and just found a workaround:

  1. Upload your tracks.
  2. Only fill out the title field. Leave all other fields blank and don't change any settings from the default.
  3. Once the files are uploaded, you can rename and re-order them as you want. Hit 'Save'
  4. Now the playlist is created. You can edit it playlist and add all of the information and settings you need.
  5. Make sure you have no more than 30 tags.
  6. Double-check your licensing metadata -- because mine set itself to "Creative Commons".
  7. When you hit 'save' to make final changes, just wait. It's going to give you an error message that says "Error saving playlist. Please try again." When the animation stops moving on the greyed out save button (which read 'Save Changes" again but in grey), that's the signal that you're finished... if you then go to your actual account and look under Tracks you'll see that the changes were, in fact, saved.
Hey guys, I'm having the same issue, I tried what the dude above said, nothing.

I hit the "inspect" tool on the save button and it seems as if there are 4 errors, at times 5, causing this. Does anyone know a way around this issue? I have an album that has to be uploaded ASAP.

Reply