Question

Twitter displaying wrong thumbnail

  • 9 March 2015
  • 9 replies
  • 3038 views

When I share my new track to Twitter the thumbnail displays my OLD profile picture instead of the cover art.. I tried making my profile picture the cover & re-sharing but it still displays my old profile pic in the thumbnail next to the link.. Any help ?

9 replies

Userlevel 7
Badge +2
Hi Bengle,

Thanks for writing into the help forum and apologies for the frustration caused. We are working with Twitter to help rectify this issue that affects some tracks. Could you please clear your cache and cookies, start with a fresh window and give it another try? Also, please send me a link to the track, I would like to see if I can replicate the glitch.

Thanks again,
Gina
Hi Bengle,

Thanks for writing into the help forum and apologies for the frustration caused. We are working with Twitter to help rectify this issue that affects some tracks. Could you please clear your cache and cookies, start with a fresh window and give it another try? Also, please send me a link to the track, I would like to see if I can replicate the glitch.

Thanks again,
Gina

Thanks, here's a link https://soundcloud.com/bengle/thinking-bout-ya-prod-2213 & I tried to share off mobile soundcloud app.. How do I delete the cookies & cache form their?
I have the same problem - I'm sharing to twitter and not getting the current thumbnail for the track in question. Would be grateful for a fix ASAP.

Jules
Track in question is https://soundcloud.com/trailermen/open-your-eyes-featuring-tori-beaumont

Have just tested it in a brand new (test) Twitter account and it loads the correct artwork. However, in my existing Twitter account it shows an old generic thumbnail. Is there any way of getting Twitter to refresh it's image cache or forcing a new image through from Soundcloud?

Thanks for any help.

Jules
Mmm ... just refreshed on that test Twitter account and now it's showing the old, generic artwork! This is frustrating.

Jules
Hi Bengle,

Thanks for writing into the help forum and apologies for the frustration caused. We are working with Twitter to help rectify this issue that affects some tracks. Could you please clear your cache and cookies, start with a fresh window and give it another try? Also, please send me a link to the track, I would like to see if I can replicate the glitch.

Thanks again,
Gina

hey whats going im having the same issue, i uploaded my new record and it shows the thumbnail to an old record when i post on twitter which confuses my followers, anyway you can fix this glitch on your end ? here is the link : https://soundcloud.com/rosewoodbape/miles

my twitter is@rosewoodbape so you can see the glitch
Mmm ... just refreshed on that test Twitter account and now it's showing the old, generic artwork! This is frustrating.

Jules

hey whats going im having the same issue, i uploaded my new record and it shows the thumbnail to an old record when i post on twitter which confuses my followers, anyway you can fix this glitch on your end ? here is the link : https://soundcloud.com/rosewoodbape/miles

my twitter is@rosewoodbape so you can see the glitch
Userlevel 7
Badge +3
Mmm ... just refreshed on that test Twitter account and now it's showing the old, generic artwork! This is frustrating.

Jules

Hi there Jules,

Thanks for following up on this and for explaining the troubleshooting you did. I'm afraid that the info of what exactly is getting shared from your account sits in Twitter's cache - this should refresh soon, so I'd suggest to let it sit for a moment.

The unfortunate thing is that we have little control over Twitter's cache. Facebook has a debugging tool where their cache can be refreshed manually (thought even that is quite the hasle). Our developers are looking into this, working together with Twitter and Facebook, so I'm hoping that this can be improved in the future.

Hope this helps to shed some light on this.

Cheers
Mathis
Userlevel 7
Badge +3
Hi Bengle,

Thanks for writing into the help forum and apologies for the frustration caused. We are working with Twitter to help rectify this issue that affects some tracks. Could you please clear your cache and cookies, start with a fresh window and give it another try? Also, please send me a link to the track, I would like to see if I can replicate the glitch.

Thanks again,
Gina

Hi there Bengle,

Thank you for following up on this - the issue is actually more on our / on twitter's end then it is rooted in your local cache. Thus, I'm afraid there is not an easy troubleshooting steps for you to perform to fix this. Twitter's cache should refresh over time. If you need to share the track immediately, changing the direct link to the track might help with this, as Twitter would then grab the most up to date info and doesn't fall back to its cache. However, this is something you will need to do on a computer. Also, changing the URL of a track is not always something you would want to do, especially if you've provided others with the original URL already.

Long story short - we're hoping to be able to fix and improve this soon, and I really wish there was an easy fix for this :-/

Thank you for your patience and all the best,
Mathis

Reply