Question

Uploaded tracks not showing up on our profile


Hi!

We are trying to upload tracks via a java-code in Processing. We have managed to upload a track, but it will not show up on the newsfeed or on our profile. The track shows up if we go to the track page: https://soundcloud.com/loopify/tracks. If any user goes to this page and plays the track, it will finally show up on the profile (and in the stream of our followers).

This is a big problem for us because we want the music to be easily found by other users. Is it possible to fix this problem and make the tracks show up on our profile immediately after upload?

Best regards,
Emilie and Anja

15 replies

Userlevel 7
Badge +2
Hi Emilie and Anja,

Thanks for writing into the forum. Is the title of your track: Opplasting med java2? If so, I can see it on your profile as well as on the individual track page. Is this showing up for you ok now? Please let me know!

Thanks again,
Gina
Thank you for your response!

I think that must be a track we have already played once form a different user (and after playing the track it shows up on our profile by some odd reason).

I have now uploaded a new track (called "Test upload with java"). It is not showing up on our profile. We can see it on the track page, but are not able to play the track (it has the message "This track is being processed").

If I log in with a different user, the track is playable from the track page, but it still does not show up on Loopify's profile page. As mentioned before, if the track is played once, it finally shows up on the profile page and in the stream of Loopify's followers.

- Emilie and Anja
Looks like someone already played that track (and then it shows up), so i'm putting up a new one: "Test upload with java 2".
Userlevel 7
Badge +2
Hi,

Both tracks are showing ok for me. For you?

-Gina
Now it shows up. Did you have to play the track before it showed up on the profile (I can see that it has 1 play now)? The problem is that the tracks do not show up unless they are played once. I'm going to upload a new track.

- Emilie and Anja
Userlevel 7
Badge +2
Now it shows up. Did you have to play the track before it showed up on the profile (I can see that it has 1 play now)? The problem is that the tracks do not show up unless they are played once. I'm going to upload a new track.

- Emilie and Anja

No I did not play it. Sometimes a tracks can be a bit delayed to post. Let me know if you have any further questions.

-G
Userlevel 7
Badge +3
Now it shows up. Did you have to play the track before it showed up on the profile (I can see that it has 1 play now)? The problem is that the tracks do not show up unless they are played once. I'm going to upload a new track.

- Emilie and Anja

Hi again,

Thanks for writing back. I can see that you've just uploaded another track a few minutes ago. I can currently reproduce the issue - I can only see 2 tracks on your account. I've reached out to our developers about this, and they say that if it takes a moment, then this might be due to caching sometimes. Thus, if this track still doesn't show in 30-60 minutes (I haven't listened to the track yet), I'll reach back to our developers to look into this for you.

Thanks for your patience, much appreciated!
Cheers
Mathis
Now it shows up. Did you have to play the track before it showed up on the profile (I can see that it has 1 play now)? The problem is that the tracks do not show up unless they are played once. I'm going to upload a new track.

- Emilie and Anja

I do not think it is because the tracks are delayed to post. The tracks are stuck on "This track is being processed" (if i'm logged in as Loopify) for hours if they are not played by others.

- Emilie
Now it shows up. Did you have to play the track before it showed up on the profile (I can see that it has 1 play now)? The problem is that the tracks do not show up unless they are played once. I'm going to upload a new track.

- Emilie and Anja

To clarify: When i am logged on as Loopify, the uploaded track shows the message "This track is being processed" and I am not able to play it.
When i am logged on as an other user I can not see the uploaded track on Loopify's profile page, but it is available on the track page (https://soundcloud.com/loopify/tracks). If I play the track once from this page, it suddenly shows up on Loopify's profile page. Logged in as Loopify, the track no longer shows the message "This track is being processed" and is now playable from this profile as well.

- Emilie
Now it shows up. Did you have to play the track before it showed up on the profile (I can see that it has 1 play now)? The problem is that the tracks do not show up unless they are played once. I'm going to upload a new track.

- Emilie and Anja

Is it possible that the problem is caused by the API wrapper? I'm using the Soundcloud Java API wrapper (https://github.com/soundcloud/java-api-wrapper). It says that Soundcloud has dropped the support for this wrapper. I have tried to code in Python instead (using your HTTP API Guide), but i'm getting the exact same problem.

Thanks again,
Emilie
Now it shows up. Did you have to play the track before it showed up on the profile (I can see that it has 1 play now)? The problem is that the tracks do not show up unless they are played once. I'm going to upload a new track.

- Emilie and Anja

Now it shows up. Did you have to play the track before it showed up on the profile (I can see that it has 1 play now)? The problem is that the tracks do not show up unless they are played once. I'm going to upload a new track.

- Emilie and Anja

This is how it looks from the Loopify profile. "Test upload with java 4" has been stuck on processing for 55 mins (and it's a 2 sec. track!). "Test upload with java 3" havs been played two times by other users, after this it became playable from the Loopify profile.
Now it shows up. Did you have to play the track before it showed up on the profile (I can see that it has 1 play now)? The problem is that the tracks do not show up unless they are played once. I'm going to upload a new track.

- Emilie and Anja

One more thing: There is no problem with uploading the usual way (log in to the account in a web browser and go to https://soundcloud.com/upload). The uploaded tracks show up on the profile right away.
I'm having the problem when using java or python code for uploading.
Userlevel 7
Badge +3
Now it shows up. Did you have to play the track before it showed up on the profile (I can see that it has 1 play now)? The problem is that the tracks do not show up unless they are played once. I'm going to upload a new track.

- Emilie and Anja

Hi again Loopify,

Aha! Thank you for adding this piece of information to the convo - this changes things indeed. SoundCloud does not have a dedicated API support team at this time. Our customer support team is focused on providing account-related support and I am afraid we do not have the necessary skills to handle enquiries about SoundCloud’s API.

That being said; If you are looking for help in building an application on top of SoundCloud’s API, I would recommend looking through SoundCloud’s stackoverflow page (http://stackoverflow.com/tags/soundcloud), and reviewing our developer website (https://developers.soundcloud.com/). These are the support resources we have in place for app developers.

If you have a question about acceptable commercial use of SoundCloud’s API, then we would please ask you to refer to the following section of our API terms of use (https://developers.soundcloud.com/docs/api/terms-of-use#commercial). Any application reported to us which violates the API terms of use will have their access to the SoundCloud API permanently revoked.

If after following the suggestions above you are still seeking support on using SoundCloud’s API please get back in touch with a link to a Stackoverflow post about your question and we can follow up with a member of our engineering team and ask them to respond to you there.

Hope this helps!

Cheers
Mathis

Reply