Uploading issues

  • 8 September 2016
  • 5 replies


I just signed up to soundcloud, but I can't upload any tracks. I tried different tracks in different formats, but the percentage bar won't move. Neither can I upload a head picture, although a profil pic was possible.

Is there any solution to that issue?

Best regards!

5 replies

Userlevel 3
Hi there,

Maybe you hadn't yet confirmed your email address.

However this seems to be done now, please give it a couple of hours then try again.

If you still have issues uploading tracks after that, try these basic troubleshooting steps.

If these don't solve it for you, let us know in a public post so anyone who has already experienced this can help out.

Cheers. /J
Hi Jonathan!

Thanks for the reply! My address is confirmed. It still is not working. Neither uploading of a header nor a track, unfortunately the troubleshooting steps are not helping, I walked them through twice and forum posts are not helping either!

Uploading bars are still stuck:

Head Upload:

Is there any solution?

Best regards!
Hi There!

I still can't upload anything, I'd be glad if you can help me with this!

Best regards!
Userlevel 3
Hi there,

Regarding uploading tracks, after looking into our system, it seems your track has unfortunately failed to upload.

If it is still there, could you try deleting then reuploading it?

Also, to be on the safe side, make sure it is a .wav or .mp3 encoded in 44.1kHz and 16bit.

Also, if you can try uploading through an ethernet connection instead of a wifi network, that usually works best.

Lastly, for the encoding process to take place in the best possible way, we recommend you leaving all the fields empty except for the title, until the track was fully uploaded and has entered processing. (Orange half of the upload bar)

Regarding your header image: For best results, upload JPG or PNG images of at least 2480 x 520 pixels with a 2MB size limit. Also, prior to uploading a header image, make sure to clear your cache and cookies. If you still have trouble, please try a different browser, with no extensions installed and let us know if that worked.


I used another computer to upload everything, finally worked fine.

Thank you & best regards.