Question

Uploading to wordpress I can't embed the right image. Either too big for the page or the bars appear across the face creating a moustache!g

  • 28 September 2015
  • 2 replies
  • 667 views

From sounfclod to wordpress I can't embed the right image. Either it is too big for the page or the bars appear across the face creating a moustache!!g


www.celebrationsongsforyou.com find samples and A Song for Elaine to see the problem

2 replies

Userlevel 7
Badge +3
Hi there,

Hmm, let's see - so it looks like you have embedded your track 3 times on your page "http://celebrationsongsforyou.com/sample-songs-and-the-stories-behind-them/a-song-for-jane/" right now. You haven't specified which of the embedded players it is that you'd like to use, so let's work with the middle one. This is the regular html5 embedded player. The reason it looks so big is because the height parameter is currently set to 450. Changing this parameter to 166 (which happens to be the height of the visual embed that you have used underneath that will rectify the size and cut the free grey space.

I hope this helps. If you have further questions around this, please let us know here - happy to help further.

Cheers
Mathis
Hello, I have read other posts on this topic and I believe the problem that many users are facing with their soundcloud image being too large on wordpress.com is due to an error with the listed soundcloud embed code. I have highlighted the discrepancies in code in bold below.

Here is an example of the correct code, which is listed on the wordpress.com website:

[soundcloud url="https://api.soundcloud.com/tracks/206489626"; params="color=00cc11&auto_play=false&hide_related=false&show_artwork=true&visual=false" width="100%" height="166" iframe="true" /]

Here is an example of the soundcloud code, which always leads to the track image being displayed too large:

[soundcloud url="https://api.soundcloud.com/tracks/206489626"; params="color=ff5500&auto_play=false&hide_related=false&show_comments=true&show_user=true&show_reposts=false" width="100%" height="166" iframe="true" /]

This Wordpress.com webpage lists the correct code exmaple, which I believe needs to be used by soundcloud in order to stop this problem:

https://en.support.wordpress.com/soundcloud-audio-player/

Reply