Answered

Wordpress Embed Not Working

  • 10 July 2017
  • 6 replies
  • 2505 views

When I try to embed a track in my Wordpress.org page, it just displays the code and not the track.

I found an article that suggest a reason why embedding my track in a Wordpress.org page might not work; however, the workaround doesn't work for me either. Please help!

The embed share code ends in: iframe=”true” /]

Then the article tells me to append the following code to fix the problem:
“&visual=false”

The problem is I'm not sure exactly where to put it, and every place I've tried hasn't worked. Am I doing it wrong, or is that not the proper solution to my problem?
icon

Best answer by Nicolás Raiman 26 March 2019, 02:45

Hi you all, I found the solution given the right permissions to the tracks.
Link:
https://help.soundcloud.com/hc/en-us/articles/115003448567-Displaying-an-embed-code-for-your-track

Regards!
Nico
View original

6 replies

It appears that you're using the shortcode ment for wordpress.com users. Self-hosted wordpress.org however, reads regular embed code. So you just need to uncheck the 'WordPress code' box.
I understand the confusion!

Hope this helps 🙂
Thanks, but that still doesn't work. It still renders the same; just the code appears.
Userlevel 7
Badge +3
Hi there,

Were you able to work it out? Please be sure to provide the URL of your website when reporting an issue about embedding. This way, others on the community can take a look and see if they can help.

Cheers
Mathis

P.S.: General how to info can be review here on our Help Center: https://help.soundcloud.com/hc/en-us/articles/115003565128-Embedding-a-track-or-playlist-on-WordPress
No, it still doesn't work...

http://realityseeker.org/songwriting/
Userlevel 7
Badge +3
Hmm, this is an odd one.

So, I've checked the track settings and also tried to embed your track on a different test page on wordpress.com as well as on http://htmledit.squarefree.com/ (great way to test if embedding of a track works in general).

This worked properly, thus it might be something in the sourcecode that is keeping the iframe from converting into the embedded player properly. Are you using a specific theme for your website (I'm not too familiar with Wordpress, but it looks like you've set up a Shop-isle theme maybe?) If so, I'd recommend to reach out to them to see if they can provide further assistance.

In the meantime, I'd recommend you to change two things on your end to customize your SoundCloud profile a bit further.
a) Adjust your Display name and URL https://help.soundcloud.com/hc/en-us/articles/115003567968-Your-Display-Name-and-Profile-URL
b) Upload a profile image and an artwork for your track.

This should not have any impact on your embed, however will make sure your SoundCloud profile can be identified with your brand / name. :)

Please let us know how it went.

Cheers
Mathis
Hi you all, I found the solution given the right permissions to the tracks.
Link:
https://help.soundcloud.com/hc/en-us/articles/115003448567-Displaying-an-embed-code-for-your-track

Regards!
Nico

Reply